iPhone OS 3.0.1 Doesn't Preclude Jailbreaking Tool Usage

The iPhone Dev Team has confirmed that new iPhone 3.0.1 OS, which was released to solve a critical vulnerability in the SMS infrastructure of Apple's smartphone.

Both redsn0w and ultrasn0w won't be affected since Apple did not apparently bring in any new restrictions or features other than eliminating the threat posed by the SMS weakness.

According to IDT, "You can re-use redsn0w v0.8 we released a few weeks ago to jailbreak today’s 3.0.1 update. Just let iTunes update or restore you to official 3.0.1 then run redsn0w."

The only “trick” is that when redsn0w asks to identify the IPSW used, point it at the 3.0 IPSW instead of the 3.0.1 one. After the jailbreak, reinstall ultrasn0w 0.9 if should the unlock arise.

It has also been confirmed that 3.0.1 doesn't disable tethering. However, George Hotz confirmed that PurpleRa1n will not work at least for now.

Another company based in Manchester, iPhone Unlocking Ltd, has released an unlocking application that they say, will "enable all iPhone owners to free the network restriction caused by the latest update".

and join more than 1600 other followers

Our Comments

The iPod Touch is not affected by the SMS vulnerability but that doesn't meant that iPod Touch uses should not upgrade to the new OS version. Apple appears to have allowed a few undocumented changes to slip in actually given the fact that purplera1n doesn't work.

Related Links

Redsn0w 0.8 Works on iPhone OS 3.0.1

http://bit.ly/V6oS5

iPhone 3.0.1 redsn0w & ultrasn0w Safe for Jailbreak

http://bit.ly/udSUY

iPhone Unlocking Ltd Release an Innovative Application to Unlock the Latest 3.0.1 Firmware Version of the Apple iPhone 3G and 3Gs

http://bit.ly/4hlfnP

iPhone redsn0w jailbreak, ultrasn0w unlock not affected by iPhone 3.0.1

http://bit.ly/3OqdmN

iPhone 3.0.1 Can Still Be Jailbroken

http://bit.ly/35lLvK