HTC Sense 3.0 Not For Older Handsets Confirms HTC

The new HTC Sense 3.0 user interface which features in the newly unveiled HTC Sensation Smartphone will not be available for ‘older’ HTC devices.

The company said in a tweet that the UI’s hardware requirement won’t allow it to run on HTC devices like HTC Desire S, Desire HD and Incredible S.

“Due to Sense's hardware requirements, only our newest devices (Flyer, Evo 3D, Sensation) will be able to support it,” the company said.

The HTC Sense 3.0 UI, which is built on the Android OS, comes with 3D user interfaces, new locking system, clocks and interactive video widgets. Packed with amazing 3D animation, the UI will let users view a preview of the messages they receive. It will be pity to see such a beautiful interface restricted to select HTC Smartphones and tablets.

However, Desire S and Incredible S users won’t be completely left out in the cold as the company is soon planning to dish out a stripped down version of the new UI which will be compatible with other HTC Android Smartphones.

“Clarification: aspects of the latest HTC Sense won’t work on some previous devices. We are working to incorporate other aspects that will,” the company explained in a later tweet.