<!DOCTYPE html>
<html lang="en" dir="ltr" data-locale="GB" class="">
<head>
<!-- [METATAGS] -->
<meta charset="utf-8">
<meta name="viewport" content="width=device-width,minimum-scale=1,initial-scale=1">
<title>9 awesome Windows hacks and tricks that'll make your life easier | ITProPortal</title>
<meta name="pub_date" content="2022-03-10T16:12:01+00:00">
<meta name="description" content="We've put together nine of our favourite shortcuts, tips and tricks, to make your Windows experience as smooth and easy as possible.">
<link rel="canonical" href="https://www.itproportal.com/features/9-awesome-windows-hacks-and-tricks-thatll-make-your-life-easier/">
<meta name="robots" content="max-image-preview:large">
<link rel="apple-touch-icon" href="https://vanilla.futurecdn.net/itproportal/428415/apple-touch-icon.png">
<meta name="msapplication-TileColor" content="#000000">
<meta name="msapplication-TileImage" content="https://vanilla.futurecdn.net/itproportal/428415/apple-touch-icon.png">
<link rel="shortcut icon" href="https://vanilla.futurecdn.net/itproportal/428415/favicon.ico" size="16x16">
<link rel="shortcut icon" href="https://vanilla.futurecdn.net/itproportal/428415/apple-touch-icon.png" size="120x120">
<meta property="og:site_name" content="ITProPortal">
<meta property="og:image" content="https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-1200-80.jpg">
<meta property="og:image:width" content="1200">
<meta property="og:type" content="article">
<meta property="article:publisher" content="https://www.facebook.com/itproportal">
<meta property="og:title" content="9 awesome Windows hacks and tricks that'll make your life easier">
<meta property="og:url" content="https://www.itproportal.com/features/9-awesome-windows-hacks-and-tricks-thatll-make-your-life-easier/">
<meta property="og:description" content="Windows is incredibly versatile if you know how to use it">
<meta property="article:published_time" content="2022-03-10T16:12:01Z">
<meta property="article:modified_time" content="2022-03-10T16:12:01.475Z">
<script type="application/ld+json">
{
"@context": "https://schema.org",
"@type": "Article",
"name": "9 awesome Windows hacks and tricks that'll make your life easier",
"headline": "9 awesome Windows hacks and tricks that'll make your life easier",
"alternativeHeadline": "9 awesome Windows hacks and tricks that'll make your life easier",
"articleBody": "With so many people using Microsoft Windows in all its various forms worldwide, it&#039;s perhaps no surprise that there are a lot of tips, tricks, and hacks that you might not know about.&nbsp; Whether it&#039;s learning how to insert a checkbox in Microsoft Word, Excel, and Google Docs , how to insert a tick or a cross symbol in Microsoft Word or Excel , or how to start page numbering from a specific page in Microsoft Word , there are endless questions being asked about how to optimize Windows use. Below,&hellip;",
"datePublished": "2022-03-10T16:12:01+00:00",
"url": "https://www.itproportal.com/features/9-awesome-windows-hacks-and-tricks-thatll-make-your-life-easier/",
"thumbnailUrl": "https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-320-80.jpg",
"articleSection": "Software",
"mainEntityOfPage": {
"@context": "https://schema.org",
"@type": "WebPage",
"@id": "https://www.itproportal.com/features/9-awesome-windows-hacks-and-tricks-thatll-make-your-life-easier/"
},
"speakable": {
"@context": "https://schema.org",
"@type": "SpeakableSpecification",
"xpath": [
"/html/head/title",
"/html/head/meta[@name=\"description\"]/@content"
]
},
"publisher": {
"@context": "https://schema.org",
"@type": "Organization",
"name": "ITProPortal",
"url": "https://www.itproportal.com",
"logo": {
"@context": "https://schema.org",
"@type": "ImageObject",
"url": "https://vanilla.futurecdn.net/itproportal/media/img/itproportal.png",
"caption": "ITProPortal logo"
}
},
"image": {
"@context": "https://schema.org",
"@type": "ImageObject",
"url": "https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci.jpg",
"caption": "Windows OS booting up on a Mac",
"height": "689",
"width": "1225"
},
"creator": {
"@type": "Person",
"name": "Paul Cooper",
"url": "https://www.itproportal.com/author/paul-cooper/"
},
"author": [
{
"@type": "Person",
"name": "Paul Cooper",
"url": "https://www.itproportal.com/author/paul-cooper/"
},
{
"@type": "Person",
"name": "Will Roszczyk",
"url": "https://www.itproportal.com/author/will-roszczyk/"
}
]
}
</script>
<script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@context":"https:\/\/schema.org","@type":"ListItem","position":1,"item":{"@id":"https:\/\/www.itproportal.com\/","name":"Home"}},{"@context":"https:\/\/schema.org","@type":"ListItem","position":2,"item":{"@id":"https:\/\/www.itproportal.com\/features\/","name":"Features"}}]}</script>
<script type="application/ld+json">
{
"@context": "https://schema.org",
"@type": "WebSite",
"name": "ITProPortal",
"url": "https://www.itproportal.com",
"publisher": {
"@context": "https://schema.org",
"@type": "Organization",
"name": "ITProPortal",
"url": "https://www.itproportal.com",
"logo": {
"@context": "https://schema.org",
"@type": "ImageObject",
"url": "https://vanilla.futurecdn.net/itproportal/media/img/itproportal.png",
"caption": "ITProPortal logo"
}
},
"potentialAction": {
"@context": "https://schema.org",
"@type": "SearchAction",
"target": "https://www.itproportal.com/search/?searchTerm={query}",
"query-input": "required name=query"
}
}
</script>
<meta name="parsely-type" content="post">
<meta name="parsely-post-id" content="WGGg7KCR7TRBUrYXRCyyhN">
<meta name="parsely-pub-date" content="2022-03-10T16:12:01Z">
<meta name="parsely-title" content="9 awesome Windows hacks and tricks that'll make your life easier">
<meta name="parsely-link" content="https://www.itproportal.com/features/9-awesome-windows-hacks-and-tricks-thatll-make-your-life-easier/">
<meta name="parsely-image-url" content="https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci.jpg">
<meta name="parsely-section" content="Software">
<meta name="parsely-tags" content="Category: Software,Category: Feature,microsoft windows,windows,computers,type_listicle,channel_software,serversidehawk">
<meta name="parsely-author" content="Paul Cooper">
<meta property="fb:app_id" content="235441786508054">
<meta property="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="@itproportal">
<meta property="twitter:title" content="9 awesome Windows hacks and tricks that'll make your life easier">
<meta property="twitter:description" content="Windows is incredibly versatile if you know how to use it">
<meta property="twitter:creator" content="@itproportal">
<meta property="twitter:image" content="https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-1200-80.jpg">
<meta property="twitter:account_id" content="16318230">
<meta name="google-site-verification" content="drTP-nIQ6X7apH1SQl8VsrFab-CVeM9ZaiaHO-mCFio">
<meta name="p:domain_verify" content="10329f1fd4d0a2cd5c0d3b3b809cb4cd">
<meta property="taboola:url" content="https://www.itproportal.com/features/9-awesome-windows-hacks-and-tricks-thatll-make-your-life-easier/">
<meta name="msvalidate.01" content="CC462E6DF91492086145CA5EBDCB615E">
<meta name="theme-color" content="#53A8CE">
<link rel="dns-prefetch" href="//cdn.mos.cms.futurecdn.net">
<link rel="dns-prefetch" href="//vanilla.futurecdn.net">
<link rel="dns-prefetch" href="//widgets.hawk-assets.co.uk">
<link rel="dns-prefetch" href="//www.google-analytics.com">
<link rel="dns-prefetch" href="//cdn.onesignal.com">
<link rel="dns-prefetch" href="//cdn.parsley.com">
<link rel="dns-prefetch" href="//cdn.jwplayer.com">
<link rel="dns-prefetch" href="//cdn.adsafeprotected.com">
<link rel="dns-prefetch" href="//securepubads.g.doubleclick.net">
<link rel="dns-prefetch" href="//quantcast.mgr.consensu.org">
<link rel="dns-prefetch" href="//vendorlist.consensu.org">
<link rel="dns-prefetch" href="//sb.scorecardresearch.com">
<link rel="dns-prefetch" href="//js-sec.indexww.com">
<link rel="dns-prefetch" href="//c.amazon-adsystem.com">
<link rel="dns-prefetch" href="//ads.servebom.com">
<!-- [/METATAGS] -->
<script>
window.vanilla = window.vanilla || {};
window.VAN = window.VAN || {};
// For AB testing
// We should come up with a list of feature flags
var defaultFlags = {"clsReporting":{"enabled":true},"raygun":{"enabled":false,"rum":false,"crashReporting":false},"selligent":{"enabled":true},"jwplayer":{"typeUsed":{"JWPLAYER_CAROUSEL_DESKTOP":"NEVER","JWPLAYER_CAROUSEL_MOBILE":"NEVER","DIGITEKA_CAROUSEL_DESKTOP":"NEVER","DIGITEKA_CAROUSEL_MOBILE":"NEVER","JWPLAYER_EDITORIAL_MOBILE":"NEVER"},"voucher":{"enabled":false},"carousel":{"enabled":false}},"amp":{"enabled":true},"parsely":{"enabled":true},"onesignal":{"enabled":true},"gtm":{"vanilla":true,"sitespecific":true},"thatswhy":{"enabled":false},"stickyPrimaryNav":{"enabled":false,"mobileOn":false,"desktopOn":false},"freyr":{"enabled":true},"stickyNavSearch":{"enabled":false},"flexiCriticalCss":{"enabled":true},"remixd":{"enabled":false},"flexiAdvancedSearch":{"fields":["articleName","articleStrapline","articleSynopsis","articleBodyClean","articleAuthor"]},"elkBlockWrapper":{"productBlock":{"enabled":true}},"i18n":{"useV2":false},"sponsoredPost":{"titleFont":"'Open Sans', Arial, sans-serif","font":"'Open Sans', Arial, sans-serif","bgColor":"#fff","label":{"font":"'Open Sans', Arial, sans-serif","backgroundColor":"#e94e1b","fontSize":"0.8125rem","textColor":"#333","freeTextColor":"#e94e1b"},"categoryLink":{"backgroundColor":"#e94e1b"}}};
window.vanilla.featureFlags = Object.assign({}, defaultFlags, window.vanilla.featureFlags || {})
window.vanilla.resourceBasePath = '//vanilla.futurecdn.net/itproportal/media/shared/js/';
window.vanilla.addScript = function(src, id) {
var script = window.document.createElement('script');
script.src = src;
script.async = true;
script.id = id;
window.document.head.appendChild(script);
}; </script>
<style id="vanilla-slice-root">:root{ --affiliate-disclaimer-margin: 0;--affiliate-disclaimer-padding: 30px 24px 10px 24px;--affiliate-disclaimer-font-color: #333;--popular-box-tab-bar-color: #53A8CE;--region-redirect-banner-background: #53A8CE;--region-redirect-banner-font-color: #fff; }</style>
<style id="vanilla-slice-combined-css">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</style>
<script>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</script>
<!-- Hawk Elements -->
<style id="hawkStyles">body .hawk-nest{--white:#fff;--light-mid-grey:#ccc;--trd-blue:#2f6e91;--site-color-hover:#005f00;width:100%;letter-spacing:normal;position:relative;}body .hawk-nest[data-widget-type=price]{display:flex;}body .hawk-nest[data-widget-type=vulture]{display:flex;flex-direction:column;}body .hawk-nest[data-widget-type=button]:hover{background-color:var(--site-color-hover);}._hawk.subtitle~.hawk-nest[data-widget-type=price]{margin:16px 0;}@media (min-width:600px){._hawk.subtitle~.hawk-nest[data-widget-type=price]{margin:0;float:right;clear:none;width:50%;}.fancy_box_body ._hawk.subtitle~.hawk-nest[data-widget-type=price]{float:none;width:100%;}}.icon~.hawk-nest{clear:both;}body .prog-buying-guide .hawk-nest{display:flex;flex-direction:row;width:100%;float:none;min-height:1px;}@media (max-width:800px){body .prog-buying-guide .hawk-nest{flex-direction:column;}}body .hawk-nest[data-widget-type=inbody],body .hawk-nest[data-widget-type=seasonal]{display:inline;}.hero-image-wrapper>div .hawk-nest,.image--hero>div:first-child .hawk-nest,.jwplayer-herowrapper .hawk-nest,.jwplayer__wrapper .hawk-nest{position:static;}.hawk-nest[data-widget-type=sticky]{justify-content:center;position:fixed;bottom:0;left:0;height:90px;box-sizing:border-box;padding:10px;border-top:2px solid var(--light-mid-grey);text-align:center;background-color:var(--white);font-size:16px;z-index:9999;display:flex;}</style>
<link rel="preload" href="https://search-api.fie.futurecdn.net/css/browser/16.17.6-644bc300e53c77bc5b600ef5feca13c5452f99d3/seasonal.min.css" as="style" onload="this.rel = 'stylesheet'"><link rel="preload" href="https://search-api.fie.futurecdn.net/css/browser/itproportal.min.css" as="style" onload="this.rel = 'stylesheet'">
<!-- End Hawk Elements -->
<script type="module" id="hawk-script-es6" async src="https://search-api.fie.futurecdn.net/js/w/es6/responsive.js"></script>
<script type="nomodule" id="hawk-script" async src="https://search-api.fie.futurecdn.net/js/w/es5/responsive.js"></script>
<script id="hawkAdditionalScripts">window.hawk_widgets_endpoint="https://search-api.fie.futurecdn.net";window.hawklinks_endpoint="https://search-api.fie.futurecdn.net";</script>
<script>
window.adParameters = window.adParameters || {
site: 'itproportal',
content: 'unknown',
type: 'standard',
};
</script>
<style>
@font-face {
font-family: "Open Sans";
font-weight: 300;
font-style: normal;
src:
url("https://vanilla.futurecdn.net/itproportal/428415/media/fonts/OpenSans-Light.woff2") format("woff2"),
url("https://vanilla.futurecdn.net/itproportal/428415/media/fonts/OpenSans-Light.woff") format("woff"),
url("https://vanilla.futurecdn.net/itproportal/428415/media/fonts/OpenSans-Light.ttf") format("ttf");
font-display: optional;
}
@font-face {
font-family: "Open Sans";
font-weight: 400;
font-style: normal;
src:
url("https://vanilla.futurecdn.net/itproportal/428415/media/fonts/OpenSans.woff2") format("woff2"),
url("https://vanilla.futurecdn.net/itproportal/428415/media/fonts/OpenSans.woff") format("woff"),
url("https://vanilla.futurecdn.net/itproportal/428415/media/fonts/OpenSans.ttf") format("ttf");
font-display: optional;
}
@font-face {
font-family: "Open Sans";
font-weight: 600;
font-style: normal;
src:
url("https://vanilla.futurecdn.net/itproportal/428415/media/fonts/OpenSans-Semibold.woff2") format("woff2"),
url("https://vanilla.futurecdn.net/itproportal/428415/media/fonts/OpenSans-Semibold.woff") format("woff"),
url("https://vanilla.futurecdn.net/itproportal/428415/media/fonts/OpenSans-Semibold.ttf") format("ttf");
font-display: optional;
}
@font-face {
font-family: "Open Sans";
font-weight: 700;
font-style: normal;
src:
url("https://vanilla.futurecdn.net/itproportal/428415/media/fonts/OpenSans-Bold.woff2") format("woff2"),
url("https://vanilla.futurecdn.net/itproportal/428415/media/fonts/OpenSans-Bold.woff") format("woff"),
url("https://vanilla.futurecdn.net/itproportal/428415/media/fonts/OpenSans-Bold.ttf") format("ttf");
font-display: optional;
}
html {
font-family: 'Open Sans';
}
</style>
<style>
head.icon-invisible ~ body .icon, head.icon-invisible ~ body .list-title::before {
visibility: hidden !important;
}
</style>
<script>
var head = document.getElementsByTagName("head")[0];
if ("fonts" in document) {
head.classList.add('icon-invisible')
var font = new FontFace(
'itproportal',
'url(https://vanilla.futurecdn.net/itproportal/428415/media/fonts/itproportal.woff), url(https://vanilla.futurecdn.net/itproportal/428415/media/fonts/itproportal.ttf), url(https://vanilla.futurecdn.net/itproportal/428415/media/fonts/itproportal.eot), url(https://vanilla.futurecdn.net/itproportal/428415/media/fonts/itproportal.svg) ', {
display: 'swap'
}
)
performance.mark("font load start")
font.load().then((fontFace) => {
document.fonts.add(fontFace)
performance.mark("font load finish")
performance.measure("font load time", "font load start", "font load finish")
head.classList.remove('icon-invisible')
console.log(fontFace.family, 'loaded successfully.')
}, (fontFace) => {
console.error('Current status', font.status);
});
}
</script>
<script>window.gaCookieSet=/(?:^|;\\s*)_ga/.test(document.cookie);</script>
<script>'use strict';(function(){function g(c,a){return function(){return setTimeout(c,a)}}function h(c,a,b){b=void 0===b?function(){}:b;return function(){var d=c.createElement("script"),e=c.getElementsByTagName("script")[0],f=k({},a,{async:1});Object.keys(f).forEach(function(a){return d.setAttribute(a,f[a])});e.parentNode.insertBefore(d,e);b()}}var k=Object.assign||function(c){for(var a=1;a<arguments.length;a++){var b=arguments[a],d;for(d in b)Object.prototype.hasOwnProperty.call(b,d)&&(c[d]=b[d])}return c};
window.vanilla.addJs=function(c,a,b,d){b=void 0===b?!1:b;c=h(document,c,d);a=null!==a?g(c,a):c;b?window.reliablePageLoad.then(a):a()}})();</script>
<script>'use strict';(function(){function f(a,d){return function(){var c=a.createElement("link"),b=g({},d,{rel:"stylesheet",type:"text/css"});Object.keys(b).forEach(function(a){return c.setAttribute(a,b[a])});var e=a.getElementsByTagName("head")[0];e.parentNode.insertBefore(c,e)}}var g=Object.assign||function(a){for(var d=1;d<arguments.length;d++){var c=arguments[d],b;for(b in c)Object.prototype.hasOwnProperty.call(c,b)&&(a[b]=c[b])}return a},h=window.requestAnimationFrame||window.webkitRequestAnimationFrame||
window.mozRequestAnimationFrame||window.msRequestAnimationFrame||function(a){return window.reliablePageLoad.then(a)};window.vanilla.addCss=function(a){return h(f(document,a))}})();</script>
<script>
window.bordeaux = window.bordeaux || {};
window.bordeaux.cmd = window.bordeaux.cmd || [];
window.bordeaux.cmd.push(function(){
if (window.disableBordeaux === true) {
return;
}
if (window.dfp_config) {
var getDfpVar = function (name) {
return window.dfp_config[name] || '';
};
var getDfpList = function (name) {
var val = getDfpVar(name);
return val ? val.split(',') : [];
};
window.bordeaux.setTargeting({
source: getDfpVar ('source'),
product: getDfpVar ('product'),
kw: getDfpList('bordeaux_keywords'),
genre: getDfpList('genre'),
vertical: getDfpList('vertical'),
pagetype: getDfpVar ('page_type').replace(',', '-'),
manu: window.dfp_config.product_brand,
articleid: window.dfp_config.article_id,
sitePlatform: window.dfp_config.site_platform,
});
if ((window.dfp_config.page_type === 'homepage' ||
window.dfp_config.page_type === 'list' ||
window.dfp_config.page_type === 'tag-listing') &&
window.dfp_config.vertical) {
window.bordeaux.setPageCategory(window.dfp_config.vertical);
} else {
window.bordeaux.setPageCategory(window.dfp_config.page_type || 'fallback');
}
}
if (window.FEPProcess) {
var fep = window.FEPProcess(window.FEP_object);
window.resolveFEP(fep);
window.bordeaux.setTargeting(window.FEPSanitise({
fepPrimaryProduct: fep.primaryProduct,
fepSecondaryProducts: fep.secondaryProducts,
fepCompanies: fep.companies,
fepCategory: fep.category,
fepGroups: fep.groups,
fepPrimaryCompany: fep.primaryCompany,
primaryCategory: fep.primaryCategory,
secondaryCategories: fep.secondaryCategories,
tertiaryCategories: fep.tertiaryCategories,
}));
}
if (window.VAN.abTest !== undefined) {
window.bordeaux.setTargeting({
vanillaVariationID: window.VAN.abTest.variationId,
});
}
if (window.ffte &&
window.ffte.properties &&
window.ffte.properties.articleControlTag &&
window.ffte.properties.articleControlTag.indexOf('type_buying_guide') > -1) {
window.bordeaux.setSlotAvoidanceDistance({ mobile: 600, tablet: 600, desktop: 600 });
}
window.bordeaux.setPageTemplate("article");
if (window.FUTR && window.FUTR.Kiosq && window.FUTR.Kiosq.hasBarrier) {
window.bordeaux.setPageTemplate('article-paywalled');
}
window.bordeaux.init();
window.bordeaux.hybridId.then((id) => {
if(!window.ga) { return }
window.ga('send', 'event', 'future_id', 'set hybrid_id', '', Object.assign({}, window.analytics_ga_data, { dimension77: id, nonInteraction: true }));
});
});
</script>
<script>
const headElement = document.querySelectorAll('head')[0];
const BORDEAUX_QUERY_PARAM = 'hybrid_bordeaux_version';
const CHAMPAGNE_QUERY_PARAM = 'hybrid_champagne_version';
const bordeauxScriptTag = document.createElement('script');
bordeauxScriptTag.setAttribute("src", 'https://bordeaux.futurecdn.net/bordeaux.js');
bordeauxScriptTag.setAttribute("onerror", "handleHeaderError()");
bordeauxScriptTag.setAttribute("crossorigin", "anonymous");
bordeauxScriptTag.defer = true;
const champagneScriptTag = document.createElement('script');
champagneScriptTag.setAttribute("src", 'https://champagne.futurecdn.net/champagne.js');
champagneScriptTag.setAttribute("onerror", "handleHeaderError()");
champagneScriptTag.setAttribute("crossorigin", "anonymous");
champagneScriptTag.defer = true;
const searchParams = new URLSearchParams(window.location.search);
const qaBordeauxString = searchParams.get(BORDEAUX_QUERY_PARAM);
const qaChampagneString = searchParams.get(CHAMPAGNE_QUERY_PARAM);
if (searchParams.has(BORDEAUX_QUERY_PARAM) && qaBordeauxString) {
bordeauxScriptTag.setAttribute("src", `https://bdx.${qaBordeauxString}.public.rtb-qa-eks-euw1.futureplc.engineering/bordeaux.js`);
}
if (searchParams.has(CHAMPAGNE_QUERY_PARAM) && qaChampagneString) {
champagneScriptTag.setAttribute("src", `https://chmp.${qaChampagneString}.public.rtb-qa-eks-euw1.futureplc.engineering/champagne.js`);
}
headElement.append(bordeauxScriptTag, champagneScriptTag);
</script>
<!-- tag factory //-->
<link rel="preload" as="font" href="//vanilla.futurecdn.net/itproportal/428415/media/fonts/OpenSans-Light.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="//vanilla.futurecdn.net/itproportal/428415/media/fonts/OpenSans.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="//vanilla.futurecdn.net/itproportal/428415/media/fonts/OpenSans-Semibold.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="//vanilla.futurecdn.net/itproportal/428415/media/fonts/OpenSans-Bold.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="//vanilla.futurecdn.net/itproportal/428415/media/fonts/itproportal.woff" type="font/woff" crossorigin="anonymous">
<meta data-static-host="//vanilla.futurecdn.net/itproportal/428415" id="static-host-pattern">
<link rel="preload" as="style" href="//vanilla.futurecdn.net/itproportal/428415/media/css/itproportal.min.css">
<link rel="preload" as="script" href="//vanilla.futurecdn.net/itproportal/428415/media/shared/js/main.0750717fffcfe9881c36.bundle.js">
<link rel="preload" as="image" href="//vanilla.futurecdn.net/itproportal/media/img/missing-image.svg">
<link rel="preload" as="image" href="https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci.jpg.webp" imagesrcset="https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-480-80.jpg.webp 480w, https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-970-80.jpg.webp 970w, https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-1024-80.jpg.webp 1024w" imagesizes="(min-width: 1000px) 970px, calc(100vw - 40px)">
<style id="critical-styles">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</style>
<script type="text/javascript">
window.missingImage = function(){var missingImage = document.createElement('img');missingImage.src = '//vanilla.futurecdn.net/itproportal/media/img/missing-image.svg';return missingImage;}
var FEP_object;
var getConnectionDimensions=function(e){var n=navigator.connection||navigator.mozConnection||navigator.webkitConnection;return void 0!==n&&(e.dimension31=n.downlink,e.dimension30=n.effectiveType),e},getConnectUserDimensions={isAuthenticated:function(){var e="false",n=localStorage.getItem("connectUser");if(console.log("GA getUserDimensions",n,localStorage.getItem("connectUser")),n){n=JSON.parse(n);var i=new Date(n.exp).getTime(),o=(new Date).getTime();i>o&&(e="true")}return e}};VAN.gaDimensions=function(e,n,i,o){ga("create",e,"auto",{useAmpClientId:!0,allowLinker:!0}),n=getConnectionDimensions(n),null!=i&&ga("set",{dimension57:i}),ga("require","displayfeatures"),o.fepPrimaryProduct&&ga("set",{dimension40:o.fepPrimaryProduct}),o.fepSecondaryProducts.length&&ga("set",{dimension41:o.fepSecondaryProducts.join("|")}),o.fepPrimaryProduct[0]&&ga("set",{dimension42:o.fepPrimaryCompany}),o.fepCompanies.length>=1&&ga("set",{dimension43:o.fepCompanies.join("|")}),o.fepPrimaryProduct&&ga("set",{dimension45:o.fepPrimaryProduct}),o.fepCategory&&ga("set",{dimension46:o.fepCategory}),o.fepArticleName.length>0&&ga("set",{dimension47:o.fepArticleName}),o.fepAlgorithm&&ga("set",{dimension50:o.fepAlgorithm}),o.fepNullified?ga("set",{dimension51:"true"}):ga("set",{dimension51:"false"}),"object"==typeof o.fepGroups&&Array.isArray(o.fepGroups)&&ga("set",{dimension58:o.fepGroups.join("|")}),o.thirdCategories&&ga("set",{dimension74:o.thirdCategories.join("|")}),ga("set",{dimension13:getConnectUserDimensions.isAuthenticated(),dimension10:document.querySelector("html").getAttribute("data-locale").replace("_","-")});try{var t=document.cookie.replace(/(?:(?:^|.*;\s*)_ga\s*\=\s*([^;]*).*$)|^.*$/,"$1");t&&ga("set",{dimension59:t})}catch(a){console.log("GA ID error: ",a)}ga("require","linker");const r=window.location.search.replace(/\b[\w\.-]+@[\w\.-]+\.\w{2,4}/g,"REDACTED01");r!==window.location.search&&(n.location=window.location.href+window.location.pathname+r),ga("send","pageview",n)}; VAN.assignFep=function(a){try{var e=e||{fepPrimaryProduct:"",fepSecondaryProducts:Array(),fepCompanies:Array(),fepHawk:{},fepCategory:"",fepGroups:Array(),kwMunge:Array(),fepArticleName:"",fepPrimaryCompany:"",fepAlgorithm:"",fepNullified:"",ready:!1,primaryCategory:"",secondaryCategories:Array(),thirdCategories:Array()};if(window.FEP=e,!e.ready){if("undefined"==typeof a)throw"FEPNotReady";e.fepPrimaryProduct=a[0].adTags.primaryProduct,e.fepSecondaryProducts=a[0].adTags.secondaryProducts,e.fepCompanies=a[0].adTags.companies,e.fepCategory="object"==typeof a[0].adTags.category?"":a[0].adTags.category,e.fepGroups="undefined"!=typeof a[0].adTags.groups?a[0].adTags.groups:Array(),e.fepArticleName=a[0].articleName,e.fepAlgorithm=a[0].strategy,e.fepNullified=a[0].nullified,e.fepPrimaryCompany=null!==a[0].adTags.primaryCompany&&a[0].adTags.primaryCompany.length>=1?a[0].adTags.primaryCompany:" ","undefined"!=typeof a[0].adTags.primaryCategory&&"undefined"!=typeof a[0].adTags.secondaryCategories&&"undefined"!=typeof a[0].adTags.thirdCategories&&(e.primaryCategory=a[0].adTags.primaryCategory,e.secondaryCategories=a[0].adTags.secondaryCategories,e.thirdCategories=a[0].adTags.thirdCategories),e.fepIAB=[],e.ready=!0;var r=["fepPrimaryProduct","fepSecondaryProducts","fepCompanies","fepCategory"];r.forEach(function(a){var r=e[a];"object"==typeof r&&(r=r),e.kwMunge=e.kwMunge.concat(r)}),e.kwMunge=e.kwMunge.filter(function(a,r){return e.kwMunge.indexOf(a)==r}),"undefined"!=typeof a[0].hawkTags.primaryProduct&&(e.fepHawk.primaryProduct=a[0].hawkTags.primaryProduct),"undefined"!=typeof a[0].hawkTags.secondaryProducts&&(e.fepHawk.secondaryProducts=a[0].hawkTags.secondaryProducts),"undefined"!=typeof a[0].hawkTags.companies&&(e.fepHawk.companies=a[0].hawkTags.companies),"undefined"!=typeof a[0].hawkTags.groups&&(e.fepHawk.groups=a[0].hawkTags.groups),"undefined"!=typeof a[0].hawkTags.category&&(e.fepHawk.category=a[0].hawkTags.category)}return window.FEP=e,e}catch(o){console.log("fep ga exc "+o.message)}};;
</script>
<script>
try{
var FEP_object = [{"acceptableLanguage":true,"adTags":{"category":"microsoft_windows","companies":["Google","Unsplash"],"groups":["microsoft_windows","windows","computers"],"primaryCategory":"microsoft_windows","primaryCompany":"Microsoft","primaryProduct":"9_awesome_Windows_hacks_and_tricks_thatll_make_your_life_easier","secondaryCategories":["microsoft_windows","windows","computers"],"secondaryCompanies":["Google","Unsplash"],"secondaryProducts":["Windows_7","Windows_key","Tick","Windows_10"],"thirdCategories":[]},"articleName":"9_awesome_Windows_hacks_and_tricks_thatll_make_your_life_easier","articleType":"feature","dataSource":"provided","hawkTags":{"primaryProduct":"9_awesome_Windows_hacks_and_tricks_thatll_make_your_life_easier","secondaryProducts":["Windows_7","Windows_key","Tick","Windows_10"],"companies":["Microsoft","Google","Unsplash"],"category":"microsoft_windows","groups":["microsoft_windows","windows","computers"],"internalProductName":""},"internalProductName":"","nullified":false,"origSite":"itproportal","overrides":[],"rampTags":{"primaryProduct":"9 awesome Windows hacks and tricks thatll make your life easier","secondaryProducts":["Windows 7","Windows key","Tick","Windows 10"],"companies":["Microsoft","Google","Unsplash"],"category":"microsoft windows","groups":["microsoft windows","windows","computers"]},"site":"itproportal","strategy":"6","timestamp":1646928717,"topProductVsproductName":"0"}];
}catch(ex){
if (typeof console == "object") {
console.log(ex);
}
}
</script>
<!-- GA TPL PREMIUM -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
// Setup the FEP global object form the FEP_object
// @TODO - can the format of FEP_object be changed server side?
VAN.assignFep(FEP_object);
var ga_code = 'UA-460866-1';
var analytics_ga_data = {"dimension1":"feature","dimension2":"software|web","dimension4":"Tech_IT_ProPortal\/","dimension5":"WGGg7KCR7TRBUrYXRCyyhN","dimension6":"|microsoft_windows|windows|computers|type_listicle|channel_software|serversidehawk","dimension7":"paul_cooper","dimension8":"10-03-2022","dimension10":"EN-GB","dimension27":428415,"dimension33":"text,embed,text,heading,text,heading,image,text,heading,text,heading,image,text,heading,text,heading,image,text,heading,image,text,heading,text,heading,image,text,divider,heading,text","dimension53":"2022-03-10T16:12:01.475Z","dimension95":"feature","dimension106":"0","dimension126":"en","dimension127":"US|GB|AU|SG","dimension128":"10-03-2022"};
var version = 'vanilla-beta';
// Make sure all the GA dimensions are setup and correct
VAN.gaDimensions(ga_code, analytics_ga_data, version, window.FEP);
</script>
<!-- END GA PREMIUM -->
<script>
!function(n,e,i){if(!n){n=n||{},window.permutive=n,n.q=[],n.config=i||{},n.config.apiKey=e,n.config.environment=n.config.environment||"production";for(var o=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],r=0;r<o.length;r++){var t=o[r];n[t]=function(e){return function(){var i=Array.prototype.slice.call(arguments,0);n.q.push({functionName:e,arguments:i})}}(t)}}}(window.permutive,"253158cc-875d-4ed4-a52d-e954eca49313",{ "consentRequired": true });
window.googletag=window.googletag||{},window.googletag.cmd=window.googletag.cmd||[],window.googletag.cmd.push(function(){if(0===window.googletag.pubads().getTargeting("permutive").length){var g=window.localStorage.getItem("_pdfps");window.googletag.pubads().setTargeting("permutive",g?JSON.parse(g):[])}});
</script>
<script async src="https://6093eccf-6734-4877-ac8b-83d6d0e27b46.edge.permutive.app/6093eccf-6734-4877-ac8b-83d6d0e27b46-web.js"></script>
<script src="https://freyr.futurecdn.net/freyr.js" async></script>
<script>
window.freyr = window.freyr ? window.freyr : { cmd: [] };
window.freyr.cmd.push(function(){window.freyr.pushAndUpdate('pageLoadEvent', {"page":{"title":"9 awesome Windows hacks and tricks that'll make your life easier","url":"https:\/\/www.itproportal.com\/features\/9-awesome-windows-hacks-and-tricks-thatll-make-your-life-easier\/","region":"GB","type":"feature","category":"feature","tags":["microsoft_windows","windows","computers","type_listicle","channel_software","serversidehawk"],"number":"1"},"content":{"article":{"verticals":["software","web"],"subVerticals":null,"language":"en","authors":["paul_cooper"],"id":"WGGg7KCR7TRBUrYXRCyyhN","publishDate":{"year":"2022","month":"03","day":"10"},"updateDate":{"year":"2022","month":"03","day":"10"}}},"site":{"region":"GB","brand":"itproportal"},"product":{"primary":{"name":"9_awesome_Windows_hacks_and_tricks_thatll_make_your_life_easier","brand":"Microsoft","category":"microsoft_windows"},"secondary":{"products":["Windows_7","Windows_key","Tick","Windows_10"],"brands":["Google","Unsplash"]},"source":"fep"}})});
</script>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
window.dm = window.dm ||{ AjaxData:[]};
window.dm.AjaxEvent = function(et, d, ssid, ad){
dm.AjaxData.push({ et: et,d: d,ssid: ssid,ad: ad});
window.DotMetricsObj && DotMetricsObj.onAjaxDataUpdate();
};
var d = document,
h = d.getElementsByTagName('head')[0],
s = d.createElement('script');
s.type = 'text/javascript';
s.async = true;
s.src = 'https://uk-script.dotmetrics.net/door.js?d=' + document.location.host + '&t=itpp'; h.appendChild(s);
} ());
/* ]]> */
</script>
<script>
var trailingSlash = true;
</script>
<script>
var onesignalConfig = {
"appId" : "e38483bf-d284-46fc-8dea-3dac8f58d7ba"
};
</script>
<link rel="manifest" href="/manifest.json">
<script>
window.vanilla.featureFlags.onesignal.enabled && window.vanilla.addScript("https://cdn.onesignal.com/sdks/OneSignalSDK.js", 'onesignal');
</script>
<!-- Hawk Elements' styles -->
<style id="hawkStyles">body .hawk-nest{--white:#fff;--light-mid-grey:#ccc;--trd-blue:#2f6e91;--site-color-hover:#005f00;width:100%;letter-spacing:normal;position:relative;}body .hawk-nest[data-widget-type=price]{display:flex;}body .hawk-nest[data-widget-type=vulture]{display:flex;flex-direction:column;}body .hawk-nest[data-widget-type=button]:hover{background-color:var(--site-color-hover);}._hawk.subtitle~.hawk-nest[data-widget-type=price]{margin:16px 0;}@media (min-width:600px){._hawk.subtitle~.hawk-nest[data-widget-type=price]{margin:0;float:right;clear:none;width:50%;}.fancy_box_body ._hawk.subtitle~.hawk-nest[data-widget-type=price]{float:none;width:100%;}}.icon~.hawk-nest{clear:both;}body .prog-buying-guide .hawk-nest{display:flex;flex-direction:row;width:100%;float:none;min-height:1px;}@media (max-width:800px){body .prog-buying-guide .hawk-nest{flex-direction:column;}}body .hawk-nest[data-widget-type=inbody],body .hawk-nest[data-widget-type=seasonal]{display:inline;}.hero-image-wrapper>div .hawk-nest,.image--hero>div:first-child .hawk-nest,.jwplayer-herowrapper .hawk-nest,.jwplayer__wrapper .hawk-nest{position:static;}.hawk-nest[data-widget-type=sticky]{justify-content:center;position:fixed;bottom:0;left:0;height:90px;box-sizing:border-box;padding:10px;border-top:2px solid var(--light-mid-grey);text-align:center;background-color:var(--white);font-size:16px;z-index:9999;display:flex;}</style>
<!-- End Hawk Elements' styles -->
</head>
<body class="limit-width standard-template">
<script>window.isIE = false</script>
<!--[IE]><script>window.isIE = true</script><![endif]-->
<script>
window.amIIE = function() {
return navigator.userAgent.indexOf('MSIE') !== -1 || navigator.appVersion.indexOf('Trident/') !== -1 || window.isIE;
}
</script>
<a href="#main" class="skip-to-main-content" style="position:absolute;">Skip to main content</a>
<nav class="primary-nav">
<input type="radio" name="burgerbar-expand" class="burgerbar-none-radio" id="burgerbar-none" checked>
<input type="radio" name="burgerbar-expand" class="burgerbar-radio" id="burgerbar">
<div class="burgerbar ">
<div class="container full burgerbar-small">
<label class="button-menu unchecked menu-hamburger" for="burgerbar" onclick></label>
<label class="button-menu checked menu-hamburger" for="burgerbar-none" onclick></label>
<div class="logo" id="publisherDetails">
<a href="/">
<span class="site-logo">
<img src="https://vanilla.futurecdn.net/itproportal/media/img/itproportal.png" alt="IT Pro Portal">
</span>
<span class="hidden-header" itemprop="name">ITProPortal</span> </a>
</div> <input type="checkbox" name="burgerbar-expand" class="search-checkbox" id="search-checkbox">
<label class="button-search masthead-item " for="search-checkbox" onclick="">
<span class="desktop-text">Search</span>
<span class="icon icon-search">
<svg class="icon-svg" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 1000 1000"><path d="M720 124a422 422 0 1 0-73 654l221 222 132-131-222-222a422 422 0 0 0-58-523zm-92 504a291 291 0 1 1-412-412 291 291 0 0 1 412 411z"></path></svg> </span>
</label>
<form class="search-box" action="https://www.itproportal.com/search/" method="GET">
<input tabindex="0" type="search" name="searchTerm" placeholder="Search ITProPortal" class="search-input">
<button type="submit" class="search-submit">
<span class="icon icon-search">
<svg class="icon-svg" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 1000 1000"><path d="M720 124a422 422 0 1 0-73 654l221 222 132-131-222-222a422 422 0 0 0-58-523zm-92 504a291 291 0 1 1-412-412 291 291 0 0 1 412 411z"></path></svg> </span>
</button>
</form>
<div class="other-links">
<a href="https://www.itproportal.com/feeds/all/">
<abbr title="Really Simple Syndication">RSS</abbr>
</a>
</div>
<div class="buttons-social masthead-item">
<a data-component-tracking-label="Facebook" target="_blank" rel="noopener" href="https://www.facebook.com/itproportal" class="icon icon-circle icon-facebook" aria-label="Facebook">
<svg class="icon-svg" height="24" viewbox="0 0 24 24" width="24" xmlns="http://www.w3.org/2000/svg"><circle cx="12" cy="12" fill="#3b5998" r="12"></circle><path d="m13.079 19h-2.9v-7h-1.441v-2.408h1.442v-1.456c0-1.96.813-3.136 3.136-3.136h1.933v2.408h-1.2c-.91 0-.965.35-.965.966v1.218h2.183l-.257 2.408h-1.931z" fill="#fff"></path></svg> </a>
<a data-component-tracking-label="Twitter" target="_blank" rel="noopener" href="https://twitter.com/intent/user?screen_name=itproportal" class="icon icon-circle icon-twitter" aria-label="Twitter">
<svg class="icon-svg" height="24" viewbox="0 0 24 24" width="24" xmlns="http://www.w3.org/2000/svg"><circle cx="12" cy="12" fill="#73b4ff" r="12"></circle><path d="m19.5 7.425a6.228 6.228 0 0 1 -1.77.465 2.979 2.979 0 0 0 1.35-1.665 6.234 6.234 0 0 1 -1.95.735 3.088 3.088 0 0 0 -5.325 2.07 3.021 3.021 0 0 0 .075.69 8.789 8.789 0 0 1 -6.33-3.165 2.985 2.985 0 0 0 -.42 1.53 3.016 3.016 0 0 0 1.37 2.52 3.082 3.082 0 0 1 -1.394-.39v.045a3.049 3.049 0 0 0 2.474 2.97 3.418 3.418 0 0 1 -1.4.06 3.076 3.076 0 0 0 2.881 2.1 6.233 6.233 0 0 1 -4.561 1.245 8.811 8.811 0 0 0 4.725 1.365 8.622 8.622 0 0 0 8.745-8.625v-.39a6.231 6.231 0 0 0 1.53-1.56z" fill="#fff"></path></svg> </a>
<a data-component-tracking-label="Flipboard" target="_blank" rel="noopener" href="https://flipboard.com/@ITProPortal" class="icon icon-circle icon-flipboard" aria-label="Flipboard">
<svg class="icon-svg" height="24" viewbox="0 0 24 24" width="24" xmlns="http://www.w3.org/2000/svg"><path d="m24 12a12 12 0 1 1 -12-12 12 12 0 0 1 12 12z" fill="#f52828"></path><path d="m19 11h-4v4h-4v4h-4v-12h12z" fill="#fff"></path></svg> </a>
</div>
<template data-slice-id="slice-localeSelector" data-slice-class="locale-selector-slice"></template>
</div>
</div>
<div class="wrapper">
<div class="menuitems container full">
<ul class="nav-list">
<li class="menu-item menu-item-home">
<a data-component-tracking-label="home" class="home" href="/" aria-label="home">
<i class="icon icon-home"></i> </a>
</li>
<li class="menu-item menu-item-news menu-level-1
primary-style ">
<a href="https://www.itproportal.com/news/" aria-label="News">
News
</a>
</li>
<li class="menu-item menu-item-reviews menu-level-1
primary-style ">
<a href="https://www.itproportal.com/reviews/" aria-label="Reviews">
Reviews
</a>
</li>
<li class="menu-item menu-item-features menu-level-1
primary-style ">
<a href="https://www.itproportal.com/features/" aria-label="Features">
Features
</a>
</li>
<li class="menu-item menu-item-guides menu-level-1
primary-style ">
<a href="https://www.itproportal.com/guides/" aria-label="Guides">
Guides
</a>
</li>
<li class="menu-item menu-item-security menu-level-1
primary-style ">
<a href="https://www.itproportal.com/security/" aria-label="Security">
Security
</a>
</li>
<li class="menu-item menu-item-business menu-level-1
primary-style ">
<a href="https://www.itproportal.com/business/" aria-label="Business">
Business
</a>
</li>
<li class="menu-item menu-item-enterprise menu-level-1
primary-style ">
<a href="https://www.itproportal.com/enterprise/" aria-label="Enterprise">
Enterprise
</a>
</li>
<li class="menu-item menu-item-categories menu-level-1
has-submenu menu-item-hover-reveal primary-style ">
<span tabindex="0">Categories <i class="icon icon-arrow-down"></i><i class="icon icon-arrow-right"></i></span>
<ul class="sub-menu">
<li class="sub-menu-item menu-level-2 primary-style">
<a href="https://www.itproportal.com/resources/" aria-label="Resources">Resources</a>
</li>
<li class="sub-menu-item menu-level-2 primary-style">
<a href="https://www.itproportal.com/hardware/" aria-label="Hardware">Hardware</a>
</li>
<li class="sub-menu-item menu-level-2 primary-style">
<a href="https://www.itproportal.com/software/" aria-label="Software">Software</a>
</li>
<li class="sub-menu-item menu-level-2 primary-style">
<a href="https://www.itproportal.com/tag/artificial-intelligence/" aria-label="AI">AI</a>
</li>
<li class="sub-menu-item menu-level-2 primary-style">
<a href="https://www.itproportal.com/mobile/" aria-label="Mobile">Mobile</a>
</li>
<li class="sub-menu-item menu-level-2 primary-style">
<a href="https://www.itproportal.com/networks/" aria-label="Networks">Networks</a>
</li>
<li class="sub-menu-item menu-level-2 primary-style">
<a href="https://www.itproportal.com/startups/" aria-label="Startups">Startups</a>
</li>
<li class="sub-menu-item menu-level-2 primary-style">
<a href="https://www.itproportal.com/cloud/" aria-label="Cloud">Cloud</a>
</li>
<li class="sub-menu-item menu-level-2 primary-style">
<a href="https://www.itproportal.com/guides/the-best-vpn-service/" aria-label="VPNs">VPNs</a>
</li>
</ul>
</li>
</ul>
<div class="nav-sub-set-container subsite-container">
<div class="menu-item menu-item-none menu-item-nav-sub-set">
<a href="https://docs.google.com/forms/d/e/1FAIpQLSf6_n8bcuPj4g7zbA6XJIb8101sG9DjI50WFVFn3h6MX9bAsQ/viewform" class="subsite_subnav-item subsite_subnav-item--submit-form" target="_blank" rel="noreferrer noopener">
Submit Article
</a>
</div>
</div>
</div>
</div> </nav>
<div class="dfp-leaderboard-container">
<div class="dfp-leaderboard-background"></div>
</div>
<div id="main" class="container full " tabindex="-1">
<template data-slice-id="slice-trendingbar" data-slice-class="trending-bar-container"></template>
<div id="slice-container-affiliateDisclaimerBar" class="slice-container affiliate-disclaimer-bar-slice affiliateDisclaimerBar"><aside id="affiliate-disclaimer" data-reactroot=""><p class="affiliate-disclaimer__copy">ITProPortal is supported by its audience. When you purchase through links on our site, we may earn an affiliate commission. <a href="https://www.futureplc.com/terms-conditions/">Learn more</a></p></aside></div>
<div id="top-leaderboard" class="ad-unit"></div>
<article class="news-article " data-id="WGGg7KCR7TRBUrYXRCyyhN">
<header>
<nav class="breadcrumb" aria-label="Breadcrumbs">
<ol>
<li><a href="/">Home</a></li>
<li><a href="https://www.itproportal.com/features/">Features</a></li>
</ol>
</nav>
<h1>9 awesome Windows hacks and tricks that'll make your life easier</h1>
<div class="byline-social">
<p class="byline">
By
<span class="no-wrap by-author">
<a href="https://www.itproportal.com/author/paul-cooper/" rel="author">
<span style="white-space: nowrap">Paul Cooper</span>
</a>
</span>
<span class="byline-contributors">
Contributions from
<span class="no-wrap by-author">
<a href="https://www.itproportal.com/author/will-roszczyk/" rel="author">
<span style="white-space: nowrap">Will Roszczyk</span>
</a>
</span>
</span>
published <time datetime="2022-03-10T16:12:01Z" class="no-wrap relative-date date-with-prefix">10 March 22</time>
</p>
<p class="strapline">Windows is incredibly versatile if you know how to use it</p>
<nav class="socialite-widget box less-space " data-contexturl="https://www.itproportal.com/features/9-awesome-windows-hacks-and-tricks-thatll-make-your-life-easier/">
<ul class="socialite-widget-ul">
<li class="socialite-widget-item">
<a data-component-tracking-label="Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://www.itproportal.com/features/9-awesome-windows-hacks-and-tricks-thatll-make-your-life-easier/" data-platform="facebook" target="_blank" class="facebook socialite" data-action="share" aria-label="Facebook">
<svg class="icon-svg" height="24" viewbox="0 0 24 24" width="24" xmlns="http://www.w3.org/2000/svg"><circle cx="12" cy="12" fill="#3b5998" r="12"></circle><path d="m13.079 19h-2.9v-7h-1.441v-2.408h1.442v-1.456c0-1.96.813-3.136 3.136-3.136h1.933v2.408h-1.2c-.91 0-.965.35-.965.966v1.218h2.183l-.257 2.408h-1.931z" fill="#fff"></path></svg> </a>
</li>
<li class="socialite-widget-item">
<a data-component-tracking-label="Twitter" href="https://twitter.com/intent/tweet?text=9%20awesome%20Windows%20hacks%20and%20tricks%20that%27ll%20make%20your%20life%20easier&amp;url=https://www.itproportal.com/features/9-awesome-windows-hacks-and-tricks-thatll-make-your-life-easier/" data-platform="twitter" target="_blank" class="twitter socialite" data-action="tweet" aria-label="Twitter">
<svg class="icon-svg" height="24" viewbox="0 0 24 24" width="24" xmlns="http://www.w3.org/2000/svg"><circle cx="12" cy="12" fill="#73b4ff" r="12"></circle><path d="m19.5 7.425a6.228 6.228 0 0 1 -1.77.465 2.979 2.979 0 0 0 1.35-1.665 6.234 6.234 0 0 1 -1.95.735 3.088 3.088 0 0 0 -5.325 2.07 3.021 3.021 0 0 0 .075.69 8.789 8.789 0 0 1 -6.33-3.165 2.985 2.985 0 0 0 -.42 1.53 3.016 3.016 0 0 0 1.37 2.52 3.082 3.082 0 0 1 -1.394-.39v.045a3.049 3.049 0 0 0 2.474 2.97 3.418 3.418 0 0 1 -1.4.06 3.076 3.076 0 0 0 2.881 2.1 6.233 6.233 0 0 1 -4.561 1.245 8.811 8.811 0 0 0 4.725 1.365 8.622 8.622 0 0 0 8.745-8.625v-.39a6.231 6.231 0 0 0 1.53-1.56z" fill="#fff"></path></svg> </a>
</li>
<li class="socialite-widget-item mobile-only">
<a data-component-tracking-label="Whatsapp" href="whatsapp://send?text=9%20awesome%20Windows%20hacks%20and%20tricks%20that'll%20make%20your%20life%20easierhttps://www.itproportal.com/features/9-awesome-windows-hacks-and-tricks-thatll-make-your-life-easier/?fwa" data-platform="whatsapp" class="whatsapp socialite" data-action="message" aria-label="WhatsApp">
<svg class="icon-svg" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 1000 1000"><path d="M509 0A489 489 0 0 0 18 487a482 482 0 0 0 71 252L0 1000l272-86a493 493 0 0 0 237 60c271 0 491-218 491-487S780 0 509 0zm0 893a409 409 0 0 1-225-67l-157 49 51-150a401 401 0 0 1-78-238 408 408 0 0 1 818 0c0 224-184 406-409 406zm230-295a2222 2222 0 0 0-84-44c-11-4-20-7-28 5a748 748 0 0 1-42 48c-7 8-15 8-27 2-12-7-52-22-99-66a372 372 0 0 1-66-88c-7-13 0-20 7-26l19-21c7-7 9-12 13-20 5-8 3-15 0-22l-35-94c-9-25-20-21-27-21l-24-2c-8 0-22 2-34 14s-46 41-48 102 40 122 46 131c6 8 82 141 207 195 126 55 126 38 149 37 24-1 76-27 87-56 12-29 13-54 10-59s-11-9-24-15z"></path></svg> </a>
</li>
<li class="socialite-widget-item">
<a data-component-tracking-label="Pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.itproportal.com/features/9-awesome-windows-hacks-and-tricks-thatll-make-your-life-easier/&amp;media=https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-1200-80.jpg" data-platform="pinterest" target="_blank" class="pinterest socialite" data-action="pin" aria-label="Pinterest">
<svg class="icon-svg" height="24" viewbox="0 0 24 24" width="24" xmlns="http://www.w3.org/2000/svg"><circle cx="12" cy="12" fill="#bd081c" r="12"></circle><path d="m12.336 5c-3.822 0-5.754 2.744-5.754 5.025a3.065 3.065 0 0 0 1.652 3.066.279.279 0 0 0 .407-.2l.154-.644a.373.373 0 0 0 -.113-.448 2.341 2.341 0 0 1 -.532-1.582 3.812 3.812 0 0 1 3.961-3.849 3.009 3.009 0 0 1 3.346 3.08c0 2.323-1.022 4.283-2.547 4.283a1.253 1.253 0 0 1 -1.273-1.554 17.616 17.616 0 0 0 .713-2.856 1.081 1.081 0 0 0 -1.092-1.2c-.854 0-1.553.881-1.553 2.071a2.954 2.954 0 0 0 .266 1.274l-1.038 4.383a9.389 9.389 0 0 0 -.027 3.065.109.109 0 0 0 .2.042 8.737 8.737 0 0 0 1.457-2.631l.561-2.212a2.3 2.3 0 0 0 1.959 1.008c2.59 0 4.34-2.366 4.34-5.516a4.8 4.8 0 0 0 -5.087-4.605z" fill="#fff"></path></svg> </a>
</li>
<li class="socialite-widget-item">
<a data-component-tracking-label="Flipboard" href="https://share.flipboard.com/bookmarklet/popout?title=9%20awesome%20Windows%20hacks%20and%20tricks%20that%27ll%20make%20your%20life%20easier&amp;url=https%3A%2F%2Fwww.itproportal.com%2Ffeatures%2F9-awesome-windows-hacks-and-tricks-thatll-make-your-life-easier%2F" data-platform="flipboard" target="_blank" class="flipboard socialite" data-action="flip" aria-label="Flipboard">
<svg class="icon-svg" height="24" viewbox="0 0 24 24" width="24" xmlns="http://www.w3.org/2000/svg"><path d="m24 12a12 12 0 1 1 -12-12 12 12 0 0 1 12 12z" fill="#f52828"></path><path d="m19 11h-4v4h-4v4h-4v-12h12z" fill="#fff"></path></svg> </a>
</li>
<li class="socialite-widget-item">
<a data-component-tracking-label="Email" href="mailto:?subject=I%20found%20this%20webpage&amp;body=Hi,%20I%20found%20this%20webpage%20and%20thought%20you%20might%20like%20it%20https://www.itproportal.com/features/9-awesome-windows-hacks-and-tricks-thatll-make-your-life-easier/" class="email socialite" data-platform="email" aria-label="Email">
<i class="icon icon-envelope-solid"></i>
</a>
</li>
</ul>
</nav>
</div>
</header>
<section class="content-wrapper">
<template data-slice-id="slice-stickyProductBrowser" data-slice-class="stickyProductBrowser"></template>
<div class="box less-space hero-image-wrapper" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
<div style="position:relative;width:100%;">
<div class="hero-image-padding-wrap padding-on">
<div class="hero-image-padding" style="padding-top:56.25%;">
<picture><source type="image/webp" alt="Windows OS booting up on a Mac" class=" block-image-ads hero-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" srcset="https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-480-80.jpg.webp 480w, https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-970-80.jpg.webp 970w, https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-1024-80.jpg.webp 1024w" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-original-mos="https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci.jpg"></source><source type="image/jpeg" alt="Windows OS booting up on a Mac" class=" block-image-ads hero-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" srcset="https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-480-80.jpg 480w, https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-970-80.jpg 970w, https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-1024-80.jpg 1024w" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-original-mos="https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci.jpg"></source><img src="https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-320-80.jpg" alt="Windows OS booting up on a Mac" class=" block-image-ads hero-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" srcset="https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-480-80.jpg 480w, https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-970-80.jpg 970w, https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci-1024-80.jpg 1024w" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-original-mos="https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci.jpg"></picture>
</div>
</div>
</div>
<meta itemprop="url" content="https://cdn.mos.cms.futurecdn.net/JpNKtigQt4agLAijYirvci.jpg">
<meta itemprop="height" content="600">
<meta itemprop="width" content="338">
<figcaption itemprop="caption description">
<span class="credit" itemprop="copyrightHolder">(Image credit: Unsplash)</span>
</figcaption>
</div>
<div class="left-rail-area"></div>
<div id="article-body" class="text-copy bodyCopy auto">
<p>With so many people using Microsoft Windows in all its various forms worldwide, it's perhaps no surprise that there are a lot of tips, tricks, and hacks that you might not know about.&nbsp;</p><div id="ad-unit-1" class="ad-unit"></div><p>Whether it's learning <a href="https://www.itproportal.com/guides/how-to-insert-checkbox-in-microsoft-word-excel-and-google-docs/" target="_blank">how to insert a checkbox in Microsoft Word, Excel, and Google Docs</a>, <a href="https://www.itproportal.com/guides/how-to-insert-a-tick-or-a-cross-symbol-in-microsoft-word-and-excel/" target="_blank">how to insert a tick or a cross symbol in Microsoft Word or Excel</a>, or <a href="https://www.itproportal.com/guides/how-to-start-page-numbering-from-a-specific-page-in-microsoft-word/" target="_blank">how to start page numbering from a specific page in Microsoft Word</a>, there are endless questions being asked about how to optimize Windows use.</p><aside class="hawk-nest" data-render-type="fte" data-skip="dealsy" data-widget-type="seasonal"></aside><p>Below, we've outlined nine of our best hacks and tricks to make Windows work better for you, and if you've got Windows 7 in particular, we've discussed <a href="https://www.itproportal.com/guides/11-tips-and-tricks-to-give-windows-7-a-speed-boost/" target="_blank">11 top tips and tricks</a> to use to give that OS a boost.</p><div id="desktop-in-article" class="in-article ad-unit"><div id="desktop-taboola-mid-article"></div></div><div id="mobile-in-article" class="in-article ad-unit"><div id="mobile-taboola-mid-article"></div></div><h2 id="1-shake-window-to-minimise">1. Shake window to minimise</h2><p>This is one of our favorites. If you click and drag a window, you can then give it a little shake - go on, try it! All the other windows you have open will instantly minimise, giving you a clutter-free workspace.</p><h2 id="2-deleting-browser-history-made-easy">2. Deleting browser history made easy</h2><figure class="van-image-figure inline-layout" data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:1920px;"><p class="vanilla-image-block" style="padding-top:56.25%;"><picture><source type="image/webp" alt="screenshot of Chrome history settings" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/JFWuBQYY9de4LEGmLimTyH-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/JFWuBQYY9de4LEGmLimTyH-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/JFWuBQYY9de4LEGmLimTyH-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/JFWuBQYY9de4LEGmLimTyH.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/JFWuBQYY9de4LEGmLimTyH.jpg"></source><source type="image/jpeg" alt="screenshot of Chrome history settings" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/JFWuBQYY9de4LEGmLimTyH-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/JFWuBQYY9de4LEGmLimTyH-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/JFWuBQYY9de4LEGmLimTyH-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/JFWuBQYY9de4LEGmLimTyH.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/JFWuBQYY9de4LEGmLimTyH.jpg"></source><img src="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" alt="screenshot of Chrome history settings" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/JFWuBQYY9de4LEGmLimTyH-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/JFWuBQYY9de4LEGmLimTyH-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/JFWuBQYY9de4LEGmLimTyH-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/JFWuBQYY9de4LEGmLimTyH.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/JFWuBQYY9de4LEGmLimTyH.jpg"></picture></p></div></div><figcaption itemprop="caption description" class=" inline-layout"><span class="caption-text">By using Ctrl + Shift + Del when in a web browser, you can get straight to your browsing history </span><span class="credit" itemprop="copyrightHolder">(Image credit: Future)</span></figcaption></figure><p>If you want to delete your browsing history, but don't want to go fishing through the settings on your browser, try hitting Ctrl + Shift + Del. That'll take you straight to the menu!</p><div id="ad-unit-2" class="ad-unit"></div><h2 id="3-highlight-address-bar">3. Highlight address bar</h2><p>Speaking of browsers, ever try to highlight a long URL from the browser address bar to copy or delete it? Why bother? Instead just hit F6, and the URL will automatically highlight. Magic.</p><h2 id="4-forget-ctrl-alt-del">4. Forget Ctrl + Alt + Del</h2><figure class="van-image-figure inline-layout" data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:1920px;"><p class="vanilla-image-block" style="padding-top:56.25%;"><picture><source type="image/webp" alt="screenshot of Windows task manager" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/RQZaw2kfLt8GooMGCAhyNV-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/RQZaw2kfLt8GooMGCAhyNV-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/RQZaw2kfLt8GooMGCAhyNV-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/RQZaw2kfLt8GooMGCAhyNV.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/RQZaw2kfLt8GooMGCAhyNV.jpg"></source><source type="image/jpeg" alt="screenshot of Windows task manager" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/RQZaw2kfLt8GooMGCAhyNV-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/RQZaw2kfLt8GooMGCAhyNV-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/RQZaw2kfLt8GooMGCAhyNV-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/RQZaw2kfLt8GooMGCAhyNV.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/RQZaw2kfLt8GooMGCAhyNV.jpg"></source><img src="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" alt="screenshot of Windows task manager" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/RQZaw2kfLt8GooMGCAhyNV-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/RQZaw2kfLt8GooMGCAhyNV-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/RQZaw2kfLt8GooMGCAhyNV-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/RQZaw2kfLt8GooMGCAhyNV.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/RQZaw2kfLt8GooMGCAhyNV.jpg"></picture></p></div></div><figcaption itemprop="caption description" class=" inline-layout"><span class="caption-text">You can get to Task Manager quicker by using Ctrl + Shift + Esc </span><span class="credit" itemprop="copyrightHolder">(Image credit: Future)</span></figcaption></figure><p>Most people will press Ctrl + Alt + Del when their computer crashes, and then instantly open the task manager. Instead, try hitting Ctrl + Shift + Esc to open the task manager directly. After all, if your computer's crashing, the fewer steps in the process the better.&nbsp;</p><p>You can of course open the task manager by right-clicking on the task bar, but this method has a bit more of a sleight-of-hand feeling to it.</p><h2 id="5-god-mode">5. God mode</h2><p>The Windows Master Control Panel, or "God Mode", is a shortcut to access <em>all</em> of the operating system's control panels from within a single folder. To create a such a shortcut, create a new folder on your desktop (or anywhere else) and rename it to:</p><p>GodMode.{ED7BA470-8E54-465E-825C-99712043E01C}</p><p>You can change the "GodMode" bit, but make sure the full-stop and the rest is the same. Once you've renamed it, the icon will change, and you'll have access to all Windows' most powerful features.</p><h2 id="6-entering-file-names-into-the-command-line">6. Entering file names into the command line</h2><figure class="van-image-figure inline-layout" data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:1920px;"><p class="vanilla-image-block" style="padding-top:56.25%;"><picture><source type="image/webp" alt="command line shown on a monitor" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/pH8PPhLPEBEtyBuH57QLg6-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/pH8PPhLPEBEtyBuH57QLg6-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/pH8PPhLPEBEtyBuH57QLg6-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/pH8PPhLPEBEtyBuH57QLg6.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/pH8PPhLPEBEtyBuH57QLg6.jpg"></source><source type="image/jpeg" alt="command line shown on a monitor" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/pH8PPhLPEBEtyBuH57QLg6-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/pH8PPhLPEBEtyBuH57QLg6-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/pH8PPhLPEBEtyBuH57QLg6-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/pH8PPhLPEBEtyBuH57QLg6.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/pH8PPhLPEBEtyBuH57QLg6.jpg"></source><img src="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" alt="command line shown on a monitor" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/pH8PPhLPEBEtyBuH57QLg6-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/pH8PPhLPEBEtyBuH57QLg6-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/pH8PPhLPEBEtyBuH57QLg6-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/pH8PPhLPEBEtyBuH57QLg6.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/pH8PPhLPEBEtyBuH57QLg6.jpg"></picture></p></div></div><figcaption itemprop="caption description" class=" inline-layout"><span class="caption-text">By dragging a file into the command line, you can save yourself typing the directory out </span><span class="credit" itemprop="copyrightHolder">(Image credit: Pixabay)</span></figcaption></figure><p>Once you've opened up DOS and are trying to execute a file, the most annoying thing is typing out the whole file directory: C: Libraries/Pictures etc.</p><p>Instead, try dragging the file directly into the command prompt, and the program will enter it for you. Simple!</p><h2 id="7-go-straight-to-desktop">7. Go straight to desktop</h2><figure class="van-image-figure inline-layout" data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:1920px;"><p class="vanilla-image-block" style="padding-top:56.25%;"><picture><source type="image/webp" alt="close up on a laptop keyboard and its windows key" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/DxmakbwVMmv3EA3nQjAGR5-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/DxmakbwVMmv3EA3nQjAGR5-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/DxmakbwVMmv3EA3nQjAGR5-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/DxmakbwVMmv3EA3nQjAGR5.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/DxmakbwVMmv3EA3nQjAGR5.jpg"></source><source type="image/jpeg" alt="close up on a laptop keyboard and its windows key" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/DxmakbwVMmv3EA3nQjAGR5-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/DxmakbwVMmv3EA3nQjAGR5-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/DxmakbwVMmv3EA3nQjAGR5-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/DxmakbwVMmv3EA3nQjAGR5.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/DxmakbwVMmv3EA3nQjAGR5.jpg"></source><img src="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" alt="close up on a laptop keyboard and its windows key" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/DxmakbwVMmv3EA3nQjAGR5-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/DxmakbwVMmv3EA3nQjAGR5-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/DxmakbwVMmv3EA3nQjAGR5-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/DxmakbwVMmv3EA3nQjAGR5.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/DxmakbwVMmv3EA3nQjAGR5.jpg"></picture></p></div></div><figcaption itemprop="caption description" class=" inline-layout"><span class="caption-text">The Windows button opens up another realm of shortcuts </span><span class="credit" itemprop="copyrightHolder">(Image credit: Unsplash)</span></figcaption></figure><p>Remember when Windows used to have a "Show desktop" icon on the taskbar? Well now it doesn't need to, because you can just hit Win + D. In case you don't know, the Win button is the one with the wavy Windows flag icon between the left Ctrl and Alt.</p><h2 id="8-rename-many-files-at-once">8. Rename many files at once</h2><p>If you want to give a whole load of files the same name, select them all at once and click F2. Windows will append a (1) or a (2) to the end of each file name too, so you don't get confused.</p><h2 id="9-lock-computer-instantly">9. Lock computer instantly</h2><figure class="van-image-figure inline-layout" data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:1920px;"><p class="vanilla-image-block" style="padding-top:56.25%;"><picture><source type="image/webp" alt="Windows 10 lockscreen" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/84qErGEGpErRU42kcbVY3d-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/84qErGEGpErRU42kcbVY3d-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/84qErGEGpErRU42kcbVY3d-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/84qErGEGpErRU42kcbVY3d.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/84qErGEGpErRU42kcbVY3d.jpg"></source><source type="image/jpeg" alt="Windows 10 lockscreen" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/84qErGEGpErRU42kcbVY3d-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/84qErGEGpErRU42kcbVY3d-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/84qErGEGpErRU42kcbVY3d-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/84qErGEGpErRU42kcbVY3d.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/84qErGEGpErRU42kcbVY3d.jpg"></source><img src="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" alt="Windows 10 lockscreen" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/itproportal/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/84qErGEGpErRU42kcbVY3d-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/84qErGEGpErRU42kcbVY3d-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/84qErGEGpErRU42kcbVY3d-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/84qErGEGpErRU42kcbVY3d.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/84qErGEGpErRU42kcbVY3d.jpg"></picture></p></div></div><figcaption itemprop="caption description" class=" inline-layout"><span class="caption-text">Quickly lock your laptop or PC with Win + L </span><span class="credit" itemprop="copyrightHolder">(Image credit: Future)</span></figcaption></figure><p>If you're leaving your laptop open around friends prone to changing your Facebook information for kicks, or if you just want to increase security on your PC, it's good to get into the habit of pressing Win + L every time you leave your desktop unattended.</p><p>This will revert your computer to its lock screen, meaning any pesky meddlers will have to know your password before they can post embarrassing statuses. Unlike logging out, it keeps all your windows and documents open, however.</p><hr><h2 id="further-reading-on-windows">Further reading on Windows</h2><p>Got Windows, but don't want to use Office? Take a look at our guide to the <a href="https://www.itproportal.com/guides/the-best-microsoft-office-alternatives-free-paid-and-online-mobile-office-suites/" target="_blank">best Microsoft Office alternatives</a>, whether free, paid or online. We've also listed our top picks for the <a href="https://www.itproportal.com/guides/best-email-client-on-windows/" target="_blank">best email client on Windows</a>, and the <a href="https://www.itproportal.com/guides/best-windows-10-antivirus/" target="_blank">best Windows 10 antivirus</a>.</p><p>If you're interested in <a href="https://www.itproportal.com/reviews/microsoft-remote-desktop-review/" target="_blank">Microsoft Remote Desktop</a>, we've also covered <a href="https://www.itproportal.com/features/how-to-use-microsoft-remote-desktop-connection/" target="_blank">how to use Microsoft Remote Desktop Connection</a> for any remote access needs. <a href="https://www.itproportal.com/features/microsoft-cloud-storage-is-onedrive-or-azure-right-for-your-business/" target="_blank">Microsoft cloud storage</a> comes in multiple forms, and we've reviewed <a href="https://www.itproportal.com/reviews/microsoft-onedrive-review/" target="_blank">Microsoft OneDrive</a> to see if it ranks among the <a href="https://www.itproportal.com/guides/best-cloud-storage/" target="_blank">best cloud storage</a> providers.</p><p>Finally, we've covered our <a href="https://www.itproportal.com/features/10-best-features-of-microsoft-365-for-small-businesses/" target="_blank">10 best features of Microsoft 365 for small businesses</a>, and pitted <a href="https://www.itproportal.com/features/microsoft-365-vs-google-workspace/" target="_blank">Microsoft 365 vs Google Workspace</a>.</p>
</div>
<div class="author-block author-block-with-borders">
<div class="author-identity">
<div class="author">
<a class="name" href="https://www.itproportal.com/author/paul-cooper/">
Paul Cooper
</a>
<nav class="author-block-social-nav">
<ul class="socialite-widget-ul">
</ul>
</nav>
</div>
</div>
<div class="contributors">
<strong>With contributions from</strong>
<ul class="contributors-list">
<li class="contributor-item">
<span class="no-wrap">
<a href="https://www.itproportal.com/author/will-roszczyk/" rel="author">
<span style="white-space: nowrap">Will Roszczyk</span>
</a>
</span>
<span class="no-wrap">B2B Editor - Ecommerce</span>
</li>
</ul>
</div>
</div>
<div id="this-will-be-used-for-mpu-2"></div>
<div class="box" id="articleTag">
<span class="separator-heading">Topics</span>
<div class="tag">
<a href="https://www.itproportal.com/tag/microsoft-windows/">microsoft windows</a>
</div>
<div class="tag">
<a href="https://www.itproportal.com/tag/windows/">windows</a>
</div>
<div class="tag">
<a href="https://www.itproportal.com/tag/computers/">computers</a>
</div>
</div>
</section>
<div class="xenforo-comments-see-all">
</div>
<script>
window._taboola = window._taboola || [];
var screenWidth = window.screen.width;
function taboola_is_device(device) {
if ((! device) || device === null || (typeof device) === 'undefined') return true
if (device === 'amp') return false
if (device === 'desktop' && screenWidth >= 700) return true
if (device === 'mobile' && screenWidth < 700) return true
return false
}
</script>
<script>
(function(){
var suitableDevice = taboola_is_device("desktop");
var suitablePlacement = !("Mid Article".includes('Mid Article') && "") &&
!("Mid Article".includes('Mid Article') && window.FUTR && window.FUTR.Kiosq && window.FUTR.Kiosq.hasBarrier);
if (suitableDevice && suitablePlacement) {
window._taboola.push({
mode: "thumbnails-a-mid",
container: "desktop-taboola-mid-article",
placement: "Mid Article",
target_type: "mix"
});
}
})();
</script>
<script>
(function(){
var suitableDevice = taboola_is_device("mobile");
var suitablePlacement = !("Mid Article".includes('Mid Article') && "") &&
!("Mid Article".includes('Mid Article') && window.FUTR && window.FUTR.Kiosq && window.FUTR.Kiosq.hasBarrier);
if (suitableDevice && suitablePlacement) {
window._taboola.push({
mode: "thumbnails-a-mid",
container: "mobile-taboola-mid-article",
placement: "Mid Article",
target_type: "mix"
});
}
})();
</script>
<footer class="van_taboola" id="taboola-below-article-thumbnails">
</footer>
<script>
(function(){
var suitableDevice = taboola_is_device("desktop");
var suitablePlacement = !("Below Article Thumbnails".includes('Mid Article') && "") &&
!("Below Article Thumbnails".includes('Mid Article') && window.FUTR && window.FUTR.Kiosq && window.FUTR.Kiosq.hasBarrier);
if (suitableDevice && suitablePlacement) {
window._taboola.push({
mode: "thumbnails-b",
container: "taboola-below-article-thumbnails",
placement: "Below Article Thumbnails",
target_type: "mix"
});
}
})();
</script>
<footer class="van_taboola" id="taboola-mobile-below-article-thumbnails">
</footer>
<script>
(function(){
var suitableDevice = taboola_is_device("mobile");
var suitablePlacement = !("Mobile Below Article Thumbnails".includes('Mid Article') && "") &&
!("Mobile Below Article Thumbnails".includes('Mid Article') && window.FUTR && window.FUTR.Kiosq && window.FUTR.Kiosq.hasBarrier);
if (suitableDevice && suitablePlacement) {
window._taboola.push({
mode: "thumbnails-a",
container: "taboola-mobile-below-article-thumbnails",
placement: "Mobile Below Article Thumbnails",
target_type: "mix"
});
}
})();
</script>
<footer class="van_taboola" id="">
</footer>
<script>
(function(){
var suitableDevice = taboola_is_device("amp");
var suitablePlacement = !("below-main-column".includes('Mid Article') && "") &&
!("below-main-column".includes('Mid Article') && window.FUTR && window.FUTR.Kiosq && window.FUTR.Kiosq.hasBarrier);
if (suitableDevice && suitablePlacement) {
window._taboola.push({
mode: "thumbnails-a",
container: "",
placement: "below-main-column",
target_type: ""
});
}
})();
</script>
<script>
(function(){
var delay = 0;
window.setTimeout(function() {
window._taboola.push({flush: true});
}, delay);
})();
</script>
<footer id="comment-jump">
</footer>
</article>
<aside id="sidebar">
<section class="box newsletter-signup">
<div class="separator-heading">
<span>
<i class="icon icon-envelope white">
<svg class="icon-svg" height="24" viewbox="0 0 24 24" width="24" xmlns="http://www.w3.org/2000/svg"><path d="m20.487 20.487a12 12 0 0 1 -16.974-16.975 12 12 0 0 1 16.974 16.975z"></path><g fill="#fff"><path d="m4.41 15.943 4.316-4.843-4.316-3.237z"></path><path d="m9.877 11.987-4.483 5.059h13.139l-4.34-5.227-2.278 1.655z"></path><path d="m5.658 6.953 6.257 4.723 6.282-4.723z"></path><path d="m19.588 7.84-4.1 3.092 4.1 4.891z"></path></g></svg>
</i>
<span class="newsletter-title">Get Weekly News and Analysis</span>
</span>
</div>
<div class="grey-box">
<p>Sign up below to get the latest from ITProPortal, plus exclusive special offers, direct to your inbox!</p>
<form class="emailform" method="GET" action="https://www.itproportal.com/email-signup/">
<div class="input__wrapper">
<input type="text" class="name__input" name="NAME" value>
<input type="email" class="mail__input" name="MAIL" value placeholder="Your Email Address" required>
</div>
<div class="emailform__checkbox-rows">
<div class="emailform__checkbox-row" data-newsletter-consent-type="default-market" id="emailform__consent-news-and-offers">
<label class="emailform__checkbox-row__label">
<input type="checkbox" id="emailform__consent-news-and-offers-yes" class="emailform__checkbox-row__checkbox" value="1" name="CONTACT_OTHER_BRANDS">
Contact me with news and offers from other Future brands
</label>
</div>
<div class="emailform__checkbox-row" data-newsletter-consent-type="default-market" id="emailform__consent-partners-and-sponsors">
<label class="emailform__checkbox-row__label">
<input type="checkbox" id="emailform__consent-partners-and-sponsors-yes" class="emailform__checkbox-row__checkbox" value="1" name="CONTACT_PARTNERS">
Receive email from us on behalf of our trusted partners or sponsors
</label>
</div>
</div>
<div class="submit__wrapper">
<input class="submit__button" type="submit" value="Sign me up">
</div>
<input type="hidden" class="hidden__id" name="ID" id="ID" value="PbkPj5hSTiI7DaHxA%2BxhNEnb2DC0sRfetMa8wX06DbF4AUl5zRkYymPQ7Wzu1%2BA6Sh5nStr7zk%2Bl5%2Bh9b8" data-newsletter-consent-type="default">
<input type="hidden" class="hidden__brand" name="BRAND" id="BRAND" value="ITPP" data-newsletter-consent-type="default">
<input type="hidden" class="hidden__lang" name="LANG" id="LANG" value="EN" data-newsletter-consent-type="default">
<input type="hidden" class="hidden__source" name="SOURCE" id="SOURCE" value="2" data-newsletter-consent-type="default">
</form>
<div class="successmessage --hide-me">
<p>Thank you for signing up to IT Pro Portal. You will receive a verification email shortly.</p>
</div>
<div class="failuremessage --hide-me">
<p>There was a problem. Please refresh the page and try again.</p>
</div>
<footer>
<small>By submitting your information you agree to the <a href="http://www.futureplc.com/terms-conditions/" target="_blank">Terms &amp; Conditions</a> and <a href="http://www.futureplc.com/privacy-policy/" target="_blank">Privacy Policy</a> and are aged 16 or over.</small>
</footer>
</div>
</section>
<div id="sidebar-top" class="ad-unit"></div>
<!-- FP off //-->
<div id="sidebar-popular-top" class="ad-unit"></div>
<script id="vanilla-slice-popularBox-hydrate" type="text/javascript">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</script><div id="slice-container-popularBox" class="slice-container popular-box-slice popularBox"><section class="popular-box" data-reactroot=""><div class="popular-box__label"><button type="button" class="popular-box__label__tab popular-box__label__tab--active">MOST READ</button><button type="button" class="popular-box__label__tab ">MOST SHARED</button></div><ol class="popular-box__articles-list popular-box__articles-list--active"><li class="popular-box__article-list"><div class="popular-box__article-list__container"><a title="10 promising artificial intelligence startup ideas for 2022" class="popular-box__article-list__link" href="https://www.itproportal.com/features/10-promising-artificial-intelligence-startup-ideas-for-2022/"><div class="popular-box__article-list__image-wrapper"><picture><source class="lazy-image-van-mos optional-image" type="image/webp" data-srcset="https://cdn.mos.cms.futurecdn.net/ZJdD9ewZJv7U553PxKhuHE-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/ZJdD9ewZJv7U553PxKhuHE-640-80.jpg.webp 640w, https://cdn.mos.cms.futurecdn.net/ZJdD9ewZJv7U553PxKhuHE-720-80.jpg.webp 720w, https://cdn.mos.cms.futurecdn.net/ZJdD9ewZJv7U553PxKhuHE-1280-80.jpg.webp 1280w" sizes="99vw" data-normal="/media/img/missing-image.svg" data-original-mos="https://cdn.mos.cms.futurecdn.net/ZJdD9ewZJv7U553PxKhuHE.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/ZJdD9ewZJv7U553PxKhuHE.jpg" data-pin-nopin="true"></source><source class="lazy-image-van-mos optional-image" type="image/jpeg" data-srcset="https://cdn.mos.cms.futurecdn.net/ZJdD9ewZJv7U553PxKhuHE-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/ZJdD9ewZJv7U553PxKhuHE-640-80.jpg 640w, https://cdn.mos.cms.futurecdn.net/ZJdD9ewZJv7U553PxKhuHE-720-80.jpg 720w, https://cdn.mos.cms.futurecdn.net/ZJdD9ewZJv7U553PxKhuHE-1280-80.jpg 1280w" sizes="99vw" data-normal="/media/img/missing-image.svg" data-original-mos="https://cdn.mos.cms.futurecdn.net/ZJdD9ewZJv7U553PxKhuHE.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/ZJdD9ewZJv7U553PxKhuHE.jpg" data-pin-nopin="true"></source><img src="/media/img/missing-image.svg" alt="concept image of AI" class="popular-box__article-list__image lazy-image-van-mos optional-image" sizes="99vw" data-normal="/media/img/missing-image.svg" data-original-mos="https://cdn.mos.cms.futurecdn.net/ZJdD9ewZJv7U553PxKhuHE.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/ZJdD9ewZJv7U553PxKhuHE.jpg" data-pin-nopin="true"></picture></div></a><div class="popular-box__article-list__content"><div class="popular-box__article-list__number-text">1</div><div class="popular-box__article-list__heading"><a class="popular-box__article-list__link" href="https://www.itproportal.com/features/10-promising-artificial-intelligence-startup-ideas-for-2022/">10 promising artificial intelligence startup ideas for 2022</a></div></div></div></li><li class="popular-box__article-list"><div class="popular-box__article-list__container"><div class="popular-box__article-list__content" style="position:unset"><div class="popular-box__article-list__number-text">2</div><div class="popular-box__article-list__heading"><a class="popular-box__article-list__link" href="https://www.itproportal.com/features/10-effective-steps-for-preventing-cyberattacks-on-your-business/">10 effective steps for preventing cyberattacks on your business</a></div></div></div></li><li class="popular-box__article-list"><div class="popular-box__article-list__container"><div class="popular-box__article-list__content" style="position:unset"><div class="popular-box__article-list__number-text">3</div><div class="popular-box__article-list__heading"><a class="popular-box__article-list__link" href="https://www.itproportal.com/guides/11-tips-and-tricks-to-give-windows-7-a-speed-boost/">11 tips and tricks to give Windows 7 a speed boost</a></div></div></div></li><li class="popular-box__article-list"><div class="popular-box__article-list__container"><div class="popular-box__article-list__content" style="position:unset"><div class="popular-box__article-list__number-text">4</div><div class="popular-box__article-list__heading"><a class="popular-box__article-list__link" href="https://www.itproportal.com/guides/how-to-start-page-numbering-from-a-specific-page-in-microsoft-word/">How to start page numbering from a specific page in Microsoft Word</a></div></div></div></li><li class="popular-box__article-list"><div class="popular-box__article-list__container"><div class="popular-box__article-list__content" style="position:unset"><div class="popular-box__article-list__number-text">5</div><div class="popular-box__article-list__heading"><a class="popular-box__article-list__link" href="https://www.itproportal.com/guides/best-cloud-computing-services/">Best cloud computing services in 2022</a></div></div></div></li></ol><ol class="popular-box__articles-list "><li class="popular-box__article-list"><div class="popular-box__article-list__container"><a title="5G could play a critical role in the fight against climate change" class="popular-box__article-list__link" href="https://www.itproportal.com/news/5g-could-play-a-critical-role-in-the-fight-against-climate-change/"><div class="popular-box__article-list__image-wrapper"><picture><source class="lazy-image-van-mos optional-image" type="image/webp" data-srcset="https://cdn.mos.cms.futurecdn.net/8ZhP9pLLYmKxpNXugQrhCJ-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/8ZhP9pLLYmKxpNXugQrhCJ-640-80.jpg.webp 640w, https://cdn.mos.cms.futurecdn.net/8ZhP9pLLYmKxpNXugQrhCJ-720-80.jpg.webp 720w, https://cdn.mos.cms.futurecdn.net/8ZhP9pLLYmKxpNXugQrhCJ-1280-80.jpg.webp 1280w" sizes="99vw" data-normal="/media/img/missing-image.svg" data-original-mos="https://cdn.mos.cms.futurecdn.net/8ZhP9pLLYmKxpNXugQrhCJ.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/8ZhP9pLLYmKxpNXugQrhCJ.jpg" data-pin-nopin="true"></source><source class="lazy-image-van-mos optional-image" type="image/jpeg" data-srcset="https://cdn.mos.cms.futurecdn.net/8ZhP9pLLYmKxpNXugQrhCJ-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/8ZhP9pLLYmKxpNXugQrhCJ-640-80.jpg 640w, https://cdn.mos.cms.futurecdn.net/8ZhP9pLLYmKxpNXugQrhCJ-720-80.jpg 720w, https://cdn.mos.cms.futurecdn.net/8ZhP9pLLYmKxpNXugQrhCJ-1280-80.jpg 1280w" sizes="99vw" data-normal="/media/img/missing-image.svg" data-original-mos="https://cdn.mos.cms.futurecdn.net/8ZhP9pLLYmKxpNXugQrhCJ.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/8ZhP9pLLYmKxpNXugQrhCJ.jpg" data-pin-nopin="true"></source><img src="/media/img/missing-image.svg" alt="5G" class="popular-box__article-list__image lazy-image-van-mos optional-image" sizes="99vw" data-normal="/media/img/missing-image.svg" data-original-mos="https://cdn.mos.cms.futurecdn.net/8ZhP9pLLYmKxpNXugQrhCJ.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/8ZhP9pLLYmKxpNXugQrhCJ.jpg" data-pin-nopin="true"></picture></div></a><div class="popular-box__article-list__content"><div class="popular-box__article-list__number-text">1</div><div class="popular-box__article-list__heading"><a class="popular-box__article-list__link" href="https://www.itproportal.com/news/5g-could-play-a-critical-role-in-the-fight-against-climate-change/">5G could play a critical role in the fight against climate change</a></div></div></div></li><li class="popular-box__article-list"><div class="popular-box__article-list__container"><div class="popular-box__article-list__content" style="position:unset"><div class="popular-box__article-list__number-text">2</div><div class="popular-box__article-list__heading"><a class="popular-box__article-list__link" href="https://www.itproportal.com/news/more-and-more-uk-businesses-are-facing-password-security-breaches/">More and more UK businesses are facing password security breaches</a></div></div></div></li><li class="popular-box__article-list"><div class="popular-box__article-list__container"><div class="popular-box__article-list__content" style="position:unset"><div class="popular-box__article-list__number-text">3</div><div class="popular-box__article-list__heading"><a class="popular-box__article-list__link" href="https://www.itproportal.com/features/cyber-attack-fallout-the-knock-on-effects-a-business-can-suffer/">Cyber-attack fallout: the knock-on effects a business can suffer</a></div></div></div></li><li class="popular-box__article-list"><div class="popular-box__article-list__container"><div class="popular-box__article-list__content" style="position:unset"><div class="popular-box__article-list__number-text">4</div><div class="popular-box__article-list__heading"><a class="popular-box__article-list__link" href="https://www.itproportal.com/features/cybersecurity-predictions-and-best-practices-in-2022/">Cybersecurity predictions and best practices in 2022</a></div></div></div></li><li class="popular-box__article-list"><div class="popular-box__article-list__container"><div class="popular-box__article-list__content" style="position:unset"><div class="popular-box__article-list__number-text">5</div><div class="popular-box__article-list__heading"><a class="popular-box__article-list__link" href="https://www.itproportal.com/features/10-promising-artificial-intelligence-startup-ideas-for-2022/">10 promising artificial intelligence startup ideas for 2022</a></div></div></div></li></ol></section></div>
<div id="sidebar-popular-bottom" class="ad-unit"></div>
</aside>
</div>
<script id="selligent-tag">
function selligent_initialiser() {
window.wa = document.createElement("script"),
wa_s = document.getElementsByTagName("script")[0];
window.wa.src = "https://targetemsecure.blob.core.windows.net/138526d1-8ff9-4de4-b84a-3a11ec020ede/138526d18ff94de4b84a3a11ec020ede_1.js";
window.wa.type = "text/javascript";
wa_s.parentNode.insertBefore(wa, wa_s);
window.wa.bt_queue = [];
const properties = window.ffte?.properties;
let vertical_subsection_tags = {};
let tags = {};
if(properties) {
vertical_subsection_tags = properties.articleCategoryHandle.map(category => {
return { "tag": "VERTICAL_SUB_SECTION", "value": category }
});
tags = properties.articleTagHandle.map(tag => {
return { "tag": "TAGS", "value": tag }
});
}
window.wa.afterInit = function(){
window.wa.bt_queue.push({
"customIdentifier": "",
"async": true,
"isEvent": false,
"isTargeting": true,
"tagValues":[
{ "tag": "CATEGORY", "value": window.ffte.properties?.articleVertical || '' },
...vertical_subsection_tags,
...tags,
{ "tag": "FEP_PRODUCTS", "value": window.fepPrimaryProduct },
{ "tag": "FEP_PRODUCTS", "value": window.fepSecondaryProducts }
],
"exposedFields": [
{ "field": "Number_of_hits_in_the_last_day" },
{ "field": "Average_time__minutes__per_visit" }
]
});
}
}
window.vanilla.featureFlags.selligent.enabled && window.reliablePageLoad.then(function(){
reliableConsentGiven.then(function (consentResponse) {
if (consentResponse.consent && consentResponse.consent.gdprApplies) {
__tcfapi('getNonIABVendorConsents', 2, function (consent, success) {
// Selligent's id = 1
// Purposes for selligent = 5, 6, 8, 10
var purposes = consentResponse.consent.purpose.consents;
var relevantPurposes = [purposes[5], purposes[6], purposes[8], purposes[10]];
var consentForPurposes = relevantPurposes.every((purpose) => purpose);
if (consent.nonIabVendorConsents[1] && consentForPurposes){
selligent_initialiser();
}
});
}
});
ccpaAppliesPromise.then(function (ccpaApplies) {
if (ccpaApplies) {
selligent_initialiser();
}
});
});
</script>
<script type="module" id="hawklinks-script-es6" async src="https://search-api.fie.futurecdn.net/hl/es6/hawklinks.js"></script>
<script type="nomodule" id="hawklinks-script" async src="https://search-api.fie.futurecdn.net/hl/es5/hawklinks.js"></script>
<script>
document.addEventListener('falcon:appBootingCompleted', (async () => {
Falcon.mount({selector: '.falcon-placeholder'});
}));
</script>
<footer id="document-footer" class="container full">
<div id="document-footer-content">
<p>ITProPortal is part of Future plc, an international media group and leading digital publisher. <a href="https://www.futureplc.com" target="_blank">Visit our corporate site</a>.</p>
<nav>
<ul>
<li><a href="https://www.itproportal.com/features/about-us/" target="_blank" data-original-url="/news/itpp-about-us/">About us</a></li>
<li><a href="https://www.futureplc.com/terms-conditions/" target="_blank">Terms and conditions</a></li>
<li><a href="https://www.futureplc.com/privacy-policy/" target="_blank">Privacy policy</a></li>
<li><a href="https://www.futureplc.com/cookies-policy/" target="_blank">Cookies policy</a></li>
<li><a href="https://www.itproportal.com/features/about-us/" target="_blank" data-original-url="/advertising">Advertise with us</a></li>
<li><a href="https://www.futureplc.com/accessibility-statement/">Accessibility Statement</a></li>
<li><a href="https://www.futureplc.com/careers/" target="_blank">Careers</a></li>
</ul>
</nav>
<p>&copy;
Future Publishing Limited Quay House, The Ambury,
Bath
BA1 1UA. All rights reserved. England and Wales company registration number 2008885. </p>
</div>
</footer>
<script>
window.vanL10N = null;
</script> <!-- Begin comScore Tag -->
<script>
function comscoreIntegration() {
var TIMEOUT_DELAY = 2000;
var COMSCORE_ID = "10055482";
function callComscore(ucfrValue) {
window._comscore = window._comscore || [];
var comscorePayload = {
c1: "2",
c2: COMSCORE_ID,
};
if(ucfrValue) {
comscorePayload.cs_ucfr = ucfrValue;
}
window._comscore.push(comscorePayload);
injectComscore();
}
function callComscoreForVideo(ucfrValue) {
window._comscore = window._comscore || [];
const seconds = 600;
const comscorePayload = {
c1: "1",
c2: COMSCORE_ID,
c5: jwplayer().getDuration() > seconds ? "03" : "02",
c7: window.location.href,
c8: document.title,
c9: document.referrer
};
if(ucfrValue) {
comscorePayload.cs_ucfr = ucfrValue;
}
window._comscore.push(comscorePayload);
injectComscore();
}
function injectComscore() {
let s = document.createElement('script'), el = document.getElementsByTagName("script")[0];
s.async = true;
const URLbeginning = document.location.protocol === "https:" ? "https://sb" : "http://b";
if (window.__tcfapi) {
s.src = URLbeginning + '.scorecardresearch.com/cs/' + COMSCORE_ID + '/beacon.js';
} else {
s.src = URLbeginning + '.scorecardresearch.com/beacon.js';
}
el.parentNode.insertBefore(s, el);
}
if (window.__tcfapi) {
var timeout = window.setTimeout(function() {
callComscore();
}, TIMEOUT_DELAY);
window.__tcfapi('addEventListener', 2, function(res) {
window.__tcfapi('removeEventListener', 2, function() {}, res.listenerId);
const validStatus = ['tcloaded', 'useractioncomplete'];
if (validStatus.includes(res.eventStatus) && res.gdprApplies) {
window.clearTimeout(timeout);
callComscore(res.vendor?.consents?.[77] ? 1 : 0);
}
});
} else {
callComscore();
}
window.reliablePageLoad.then(function () {
window.document.addEventListener('jwplayerInstanceLoaded', function () {
jwplayer().on('beforePlay', function () {
callComscoreForVideo();
});
});
});
}
comscoreIntegration();
</script>
<!-- End comScore Tag -->
<script>
var dfp_config = {
"ad_unit": "10518929/Tech_IT_ProPortal/Features",
"live_ad_unit": "10518929/Tech_IT_ProPortal/",
"test_ad_unit": "10518929/Tech_IT_ProPortal_Test/",
"recovery_ad_unit": "",
"recovery_test_ad_unit": "",
"site_platform": "vanilla",
"keywords": "type_listicle,channel_software,serversidehawk,Software,Web,microsoft windows,windows,computers",
"bordeaux_keywords": "microsoft windows,windows,computers",
"article_id": "WGGg7KCR7TRBUrYXRCyyhN",
"vanilla_article_id": "WGGg7KCR7TRBUrYXRCyyhN",
"page_type": "feature",
"product_brand": "",
"product_category": "",
"product": "",
"vertical": "software,web",
"source": "",
"provertical": "",
"jwplayer": "carousel"
}
</script>
<script>
dfp_config.gallery_refresh_interval = 2;
</script>
<script>window.vanillaComponents=[{"parentIdentifier":"#article-body","targetIdentifier":".fwd-link","eventType":"click","action":"Click on Forward Linker","elementName":"Forward Linker","addMoreInfo":false},{"parentIdentifier":"#article-body","targetIdentifier":"a","excludeTargetClass":"fwd-link","eventType":"click","action":"Click on Inline Link","elementName":"Inline Link","addMoreInfo":false},{"parentIdentifier":".pagination-numerical-list","targetIdentifier":".pagination-numerical-list-item a","eventType":"click","action":"Click on Article Pagination","elementName":"Article Pagination Number","addMoreInfo":true},{"parentIdentifier":".navigation-sequential","targetIdentifier":".prev,.next","eventType":"click","action":"Click on Article Pagination","elementName":"Article Pagination Prev\/Next","addMoreInfo":true},{"parentIdentifier":".socialite-widget","targetIdentifier":"a","eventType":"click","action":"Click on Article Social","elementName":"Article Social","addMoreInfo":true},{"parentIdentifier":"#articleTag","targetIdentifier":".tag a","eventType":"click","action":"Click on Article Tag","elementName":"Article Tag","addMoreInfo":false},{"parentIdentifier":".author-block-social-nav","targetIdentifier":"a","eventType":"click","action":"Click on Author Social","elementName":"Author Social","addMoreInfo":true},{"parentIdentifier":"#article-body","targetIdentifier":"a[data-event-label=elkInjectedRelatedBlock]","eventType":"click","action":"Click on ELK Injected Related Block","elementName":"ELK Injected Related Block","addMoreInfo":false},{"parentIdentifier":".newsletter-signup","targetIdentifier":".emailform","eventType":"visible","action":"Email sign-up sidebar is visible","elementName":"SIGNUP - Side Bar","addMoreInfo":false},{"parentIdentifier":".hawk-pre-order-main-container","targetIdentifier":".hawk-pre-order-form-container","eventType":"visible","action":"Hawk Widget is visible","elementName":"HAWK WIDGET","addMoreInfo":false},{"parentIdentifier":".list-text-links-trending-panel","targetIdentifier":".listingResult a","eventType":"click","action":"Click on News","elementName":"News Article","addMoreInfo":false},{"parentIdentifier":".menuitems","targetIdentifier":".menu-item a","eventType":"click","action":"Click on Nav Item","elementName":"Nav Item","addMoreInfo":true},{"parentIdentifier":".menuitems","targetIdentifier":".menu-item-more","eventType":"hover","action":"Hover on Nav Item","elementName":"Nav Item","addMoreInfo":true},{"targetIdentifier":".burgerbar .menu-hamburger","eventType":"click","action":"Click on Mobile Hamburger","elementName":"Mobile Hamburger","addMoreInfo":false},{"parentIdentifier":".burgerbar","targetIdentifier":".buttons-social a","eventType":"click","action":"Click on Nav Social","elementName":"Nav Social","addMoreInfo":true},{"targetIdentifier":"#club-login > div","eventType":"hover","action":"Hover on PC Gamer Club","elementName":"PC Gamer Club","addMoreInfo":false},{"parentIdentifier":"#club-login","targetIdentifier":"a","eventType":"click","action":"Click on PC Gamer Club Login\/Register","elementName":"PC Gamer Club Login\/Register","addMoreInfo":false},{"parentIdentifier":".recommendation-articles","targetIdentifier":".recommended-article a","eventType":"click","action":"Click on Recommended Article","elementName":"Recommended Article","addMoreInfo":false},{"targetIdentifier":".burgerbar .button-search","eventType":"click","action":"Click on Search","elementName":"Search","addMoreInfo":false},{"targetIdentifier":".burgerbar form.search-box","eventType":"submit","action":"Submit Search","elementName":"Search","addMoreInfo":false},{"targetIdentifier":".logo > a","eventType":"click","action":"Click on Site Logo","elementName":"Site Logo","addMoreInfo":false},{"parentIdentifier":".top-featured","targetIdentifier":".feature-block-item-wrapper a","eventType":"click","action":"Click on Featured Article","elementName":"Featured Article","addMoreInfo":false},{"parentIdentifier":".trending-items","targetIdentifier":".trending-item a","eventType":"click","action":"Click on Trending Bar Item","elementName":"Trending Bar Item","addMoreInfo":false},{"parentIdentifier":".trending-bar","targetIdentifier":".brand-items a","eventType":"click","action":"Click on Trending Bar - Brand Link","elementName":"Trending Bar - Brand Link","addMoreInfo":false},{"parentIdentifier":".slice-container.popular-box-slice .popular-box ol.popular-box__articles-list:nth-of-type(1)","targetIdentifier":".popular-box__article-list","eventType":"click","action":"Click on Popular List 1","elementName":"Popular List 1","addMoreInfo":false}];</script>
<script>
var require = {waitSeconds:0};
</script>
<!-- Google Tag Manager -->
<script>
(function(){
function loadGTM(gtmCode){
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.defer=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer', gtmCode);
}
// Can't be in asset loader until we can call custom loader functions
;(window.Promise
? Promise.all([
window.reliablePageLoad,
window.reliableConsentGiven
])
: window.reliableConsentGiven
).then(function(){
setTimeout(
function(){
window.vanilla.featureFlags.gtm.sitespecific && loadGTM('GTM-5573WP')
window.vanilla.featureFlags.gtm.vanilla && loadGTM('GTM-KHCPGDF')
}, 1500);
});
})();
</script>
<!-- End Google Tag Manager -->
<script>
function loadTaboola()
{
var script = window.document.createElement('script');
script.async = 1;
script.src = '//cdn.taboola.com/libtrc/futureplc-network/loader.js';
var insertLocation = window.document.getElementsByTagName('script')[0];
insertLocation.parentNode.insertBefore(script, insertLocation);
}
window._taboola = window._taboola || [];
window._taboola.push({article: 'auto'});
(window.Promise
? window.Promise.all([window.reliablePageLoad, window.reliableConsentGiven])
: window.reliableConsentGiven
).then(function () {
var delay = 0;
window.setTimeout(loadTaboola, delay)
});
</script>
<!-- document assets - added by the article itself -->
<script>
window.vanilla.addJs({"id":"main-js","src":"\/\/vanilla.futurecdn.net\/itproportal\/428415\/media\/shared\/js\/main.0750717fffcfe9881c36.bundle.js"}, null, 0)
window.vanilla.addJs({"id":"ffte-js","src":"\/\/vanilla.futurecdn.net\/itproportal\/428415\/media\/shared\/js\/app.2a02a8a810126b12d6fc.bundle.js"}, 2000, 1)
window.vanilla.addCss({"href":"\/\/vanilla.futurecdn.net\/itproportal\/428415\/media\/css\/itproportal.min.css"})
</script> <script>
window.ffte = {"site":"itproportal","endpoint":"\/\/api.vanilla.futurecdn.net\/article","locale":"GB","lang":"en-gb","gaCode":"UA-460866-1","serverEnvironment":"live","staticHost":"vanilla.futurecdn.net\/itproportal","regionLink":"","isGlobal":false,"platform":"responsive","isKube":true,"l10ns":"{\"\":{\"GB\":{}}}","properties":{"articleProduct":[],"articleProductHandle":[],"articleType":"feature","articleTemplate":"standard","articleTagHandle":["microsoft-windows","windows","computers"],"articleTagType":["freeform","freeform","freeform"],"articleControlTag":["type_listicle","channel_software","serversidehawk"],"articleVerticalHandle":["software","web"],"articleCategoryHandle":[],"subSite":"","articleVertical":"software","id":"WGGg7KCR7TRBUrYXRCyyhN","legacyId":"WGGg7KCR7TRBUrYXRCyyhN"}}
</script>
<script id="vanilla-slice-utils">!function(e){var n={};function r(t){if(n[t])return n[t].exports;var o=n[t]={i:t,l:!1,exports:{}};return e[t].call(o.exports,o,o.exports,r),o.l=!0,o.exports}r.m=e,r.c=n,r.d=function(e,n,t){r.o(e,n)||Object.defineProperty(e,n,{enumerable:!0,get:t})},r.r=function(e){"undefined"!=typeof Symbol&&Symbol.toStringTag&&Object.defineProperty(e,Symbol.toStringTag,{value:"Module"}),Object.defineProperty(e,"__esModule",{value:!0})},r.t=function(e,n){if(1&n&&(e=r(e)),8&n)return e;if(4&n&&"object"==typeof e&&e&&e.__esModule)return e;var t=Object.create(null);if(r.r(t),Object.defineProperty(t,"default",{enumerable:!0,value:e}),2&n&&"string"!=typeof e)for(var o in e)r.d(t,o,function(n){return e[n]}.bind(null,o));return t},r.n=function(e){var n=e&&e.__esModule?function(){return e.default}:function(){return e};return r.d(n,"a",n),n},r.o=function(e,n){return Object.prototype.hasOwnProperty.call(e,n)},r.p="",r(r.s=2)}([function(e,n){e.exports=function(e,n,r){return n in e?Object.defineProperty(e,n,{value:r,enumerable:!0,configurable:!0,writable:!0}):e[n]=r,e}},function(e,n,r){var t=r(4),o=r(5),i=r(6);e.exports=function(e){return t(e)||o(e)||i()}},function(e,n,r){e.exports=r(3)},function(e,n,r){"use strict";r.r(n);var t=r(0),o=r.n(t),i=r(1),c=r.n(i);function u(e,n){var r=Object.keys(e);if(Object.getOwnPropertySymbols){var t=Object.getOwnPropertySymbols(e);n&&(t=t.filter((function(n){return Object.getOwnPropertyDescriptor(e,n).enumerable}))),r.push.apply(r,t)}return r}function f(e){for(var n=1;n<arguments.length;n++){var r=null!=arguments[n]?arguments[n]:{};n%2?u(Object(r),!0).forEach((function(n){o()(e,n,r[n])})):Object.getOwnPropertyDescriptors?Object.defineProperties(e,Object.getOwnPropertyDescriptors(r)):u(Object(r)).forEach((function(n){Object.defineProperty(e,n,Object.getOwnPropertyDescriptor(r,n))}))}return e}var a=function(e,n){return Promise.all(e.map((function(e){var r=e.endpoint,t=e.windowObject,o=e.fallback;if(window.slice[t])return Promise.resolve();return function e(){var t=arguments.length>0&&void 0!==arguments[0]?arguments[0]:"".concat(n||"","/").concat(r);return new Promise((function(n,r){var i=document.createElement("script");i.async=!0,i.onload=n,i.onerror=function(){o.length?(Promise.all(c()(o).map((function(n){var r=n.window,t=n.src;return window[r]?(window.slice[r]=window[r],Promise.resolve()):e(t).then((function(){return window.slice[r]=window[r]}))}))).then((function(){n(void 0)})),o=[]):r()},i.src=t,document.body.appendChild(i)}))}()})))};window.slice=f(f({},window.slice||{}),{},{resolveDependencies:a}),n.default=a},function(e,n){e.exports=function(e){if(Array.isArray(e)){for(var n=0,r=new Array(e.length);n<e.length;n++)r[n]=e[n];return r}}},function(e,n){e.exports=function(e){if(Symbol.iterator in Object(e)||"[object Arguments]"===Object.prototype.toString.call(e))return Array.from(e)}},function(e,n){e.exports=function(){throw new TypeError("Invalid attempt to spread non-iterable instance")}}]);</script><script>window.slice = window.slice || {};
window.slice.hostname = "https:\/\/slice.vanilla.futurecdn.net\/2-2-0\/";</script>
<script>
window.vanilla.featureFlags.parsely.enabled && window.vanilla.addScript("//cdn.parsely.com/keys/itproportal.com/p.js", 'parsely-cfg');
</script>
<script>
window.xkeys = ["itproportal-platform-responsive","itproportal-article-WGGg7KCR7TRBUrYXRCyyhN","itproportal-articletype-feature","itproportal-articletemplate-standard","itproportal-article-age-recent","itproportal-region-GB","itproportal-language-en","itproportal-modifieddate-1646928721","itproportal-author-ocbFw5arMRgxPuHmLV7s2C","itproportal-tag-5Yjem7PtPhUTb4bTU3bwNn","itproportal-tag-y9XNDvyARXLjmxF9o2tzBT","itproportal-tag-4RZrtcd4Xr5jXxaau6dukF","itproportal-tag-SSM6VN54hbrwWZ6NySN8rF","itproportal-tag-FKEYPahsEseevDEobuU2EQ"];
</script>
<script id="vanilla-slice-regionRedirectBanner-hydrate" type="text/javascript">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</script><div id="slice-container-regionRedirectBanner" class="slice-container region-redirect-banner-slice regionRedirectBanner"></div>
</body>
<script>
window.ftr_request_id = "";
</script> </html>